Selenium和Firefox对应版本及注意事项

版权声明:本文为老师傅原创文章,旨在相互尊重,共同学习和共同进步! https://blog.csdn.net/fetch001/article/details/64437979
     【Selenium】    -> 【FireFox】

       2.25.0        ->  18
       2.30.0        ->  19
       2.31.0        ->  20
       2.42.2        ->  29
       2.44.0        ->  33 (不支持31)
       2.53.0        ->  43,46(不支持47)
       2.41.0        ->  26(绿色版本)
       2.44          ->  32.0-35.0
       2.53.0-2.53.6 ->  40.0.3(本司目前使用selenium和firefox版本)


在selenium+python环境下查看selenium版本方法:

cmd下输入:pip show selenium

卸载selenium版本:

cmd下输入:pip uninstall selenium

安装: pip install selenium x.x.x(对应selenium版本)


在通过RF测试框架运行脚本时,提示浏览器方面错误,org.openqa.selenium.WebDriverException: Target URL ... is not well-formed

解决办法:

只需要在你访问的网址前加上:http://即可解决

例如:open browser     www.baidu.com    firefox运行后则会报以上错误

修改:open browser     http://www.baidu.com    firefox   运行成功



解决selenium不支持firefox低版本  
用winrar打开selenium-server.jar;
查找两个目录:customProfileDirCUSTFFCHROME和customProfileDirCUSTFF;
搜索每个目录,直到找到文件install.rdf,解压缩到一个临时目录,编辑如下行:
<em:maxVersion>2.0.0.*</em.maxVersion>
 改为
<em:maxVersion>4.0.0.*</em.maxVersion>
       
selenium-java-2.42.2版本和firefox 29.0.1版本兼容,如果升级到firefox 30+,则浏览器启动失败。可能是selenium还未同步升级,后面估计可以正常支持。
若selenium的版本和firefox不兼容,需要升级selenium的jar包,或者是升级firefox。
切记,关掉forefox的升级功能,否则连本地Windows上的脚本都跑不起来,且必须降级forefox。
升级后,selenium脚本正常启动firefox。


各firefox版本下载地址

http://ftp.mozilla.org/pub/firefox/releases/

各selenium jar包下载地址

http://selenium-release.storage.googleapis.com/index.html

在selenium下载页面 http://www.seleniumhq.org/download/ (需FQ) 各个版本的changelog中,会记录支持的firefox版本

备注:selenium V3.0之前都不支持ff47.0.所以,如果你是seleniumV3.0以及之前的版本就不要下载ff47.0以及ff47.0之后的版本了。
展开阅读全文

没有更多推荐了,返回首页