27:Mode of Sequence

总时间限制: 

1000ms

内存限制: 

65536kB

描述

Given a sequence of N number. Find the mode M in the sequence so that the number of M's appear in the sequence is maximum.

输入

First line: one positive integers N (N <= 100).
Second line: N positive integers (<= 100000).

输出

One integer M.

样例输入

7
1 3 2 4 4 3 3

样例输出

3

#include<bits/stdc++.h>//Writed by Wangzhimin Date: 2022.06.06 
using namespace std;
int num,k,a[100005];//mode 众数 初始化为0 
int main()
{
    scanf("%d",&num);
    int cnt=0,sum,i,j,n;
    for(int i=0;i<num;i++)
        {scanf("%d",&n);//输入数据 
        a[n]++;}//相应的数加1 
    for(i=0;i<100002;i++)
        if(cnt<a[i])    //如果有数量还多的 
        {
            sum=i;
            cnt=a[i];
            }
          cout<<sum;//众数     
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值