POJ2485 Highways(Kruskal算法)

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can’t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

题意描述:
给出n个路口的坐标,再给出m行已经连通的路口,然后让你输出为连通的路口中那两个路口需要相互连通。

解题思路:
先算出任意两点之间的距离,然后再把已经连通的路口的距离赋值为0,然后利用Kruscal算法,去判断只要距离不为0,就输出这俩个路口的编号。

内存【8924kB】

#include<stdio.h>
#include<math.h>

struct node
{
	int x,y;
	double v;
}p[281630];

int f[755];
void qiucksort(int left,int right)
{
	int i,j;
	struct node t;
	if(left>right)
		return ;
	i=left;
	j=right;
	while(i!=j){
		while(p[j].v>=p[left].v&&j>i)
			j--;
		while(p[i].v<=p[left].v&&j>i)
			i++;
		if(j>i){
			t=p[i];
			p[i]=p[j];
			p[j]=t;
		}
	}
	t=p[i];
	p[i]=p[left];
	p[left]=t;
	
	qiucksort(left,i-1);
	qiucksort(i+1,right);
	return ;
}

int getf(int i)
{
	if(i==f[i])
		return i;
	
	f[i]=getf(f[i]);
	return f[i];
}

int merge(int x,int y)
{
	int t1,t2;
	t1=getf(x);
	t2=getf(y);
	if(t1!=t2){
		f[t2]=t1;
		return 1;
	}
	return 0;
}

double c[755][755];
int main(void)
{
	int i,j,n,m,a,b;
	while(~scanf("%d",&n)){
		int k=1;
		for(i=1;i<=n;i++)
			scanf("%d%d",&p[i].x,&p[i].y);
		
		for(i=1;i<n;i++)
			for(j=i+1;j<=n;j++)
				c[i][j]=sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)*1.0+(p[i].y-p[j].y)*(p[i].y-p[j].y)*1.0);
			
		scanf("%d",&m);
		for(i=1;i<=m;i++){
			scanf("%d%d",&a,&b);
			c[a][b]=0;
			c[b][a]=0;
		}
		for(i=1;i<n;i++){
			for(j=i+1;j<=n;j++){
				p[k].x=i;
				p[k].y=j;
				p[k].v=c[i][j];
				k++;
			}
		}
		qiucksort(1,k-1);
		for(i=1;i<=n;i++)
			f[i]=i;
		
		int count=0;
		for(i=1;i<k;i++){
			if(merge(p[i].x,p[i].y)==1){
				if(p[i].v>0)
					printf("%d %d\n",p[i].x,p[i].y);
				count++;
			}
			if(count==n-1)
				break;
		}
		
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值