平面上的点和线——Point类、Line类 (VII)

Description
在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。
根据“append.cc”,完成Point类和Line类的构造方法和show()方法,输出各Line对象和Point对象的构造和析构次序。
接口描述:
Point::showCounter()方法:按格式输出当前程序中Point对象的计数。
Point::showSum()方法:按格式输出程序运行至当前存在过的Point对象总数。
Line::showCounter()方法:按格式输出当前程序中Line对象的计数。
Line::showSum()方法:按格式输出程序运行至当前存在过的Line对象总数。

Input
输入的第一行为N,表示后面有N行测试样例。
每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

Output
输出格式见sample。
C语言的输入输出被禁用。

Sample Input
4
0,0 1,1
1,1 2,3
2,3 4,5
0,1 1,0
Sample Output
Current : 3 points.
In total : 3 points.
Current : 6 lines.
In total : 6 lines.
Current : 17 points.
In total : 17 points.
Current : 6 lines.
In total : 7 lines.
Current : 15 points.
In total : 17 points.
Current : 6 lines.
In total : 8 lines.
Current : 17 points.
In total : 21 points.
Current : 6 lines.
In total : 9 lines.
Current : 15 points.
In total : 21 points.
Current : 6 lines.
In total : 10 lines.
Current : 17 points.
In total : 25 points.
Current : 6 lines.
In total : 11 lines.
Current : 15 points.
In total : 25 points.
Current : 6 lines.
In total : 12 lines.
Current : 17 points.
In total : 29 points.
Current : 6 lines.
In total : 13 lines.
Current : 15 points.
In total : 29 points.
Current : 9 lines.
In total : 17 lines.
Current : 21 points.
In total : 37 points.
Current : 13 lines.
In total : 21 lines.
Current : 21 points.
In total : 45 points.
HINT

Append Code
append.cc,

int main()
{
    int num, i;
    Point p(1, -2), q(2, -1), t;
    t.showCounter();
    t.showSum();
    std::cin>>num;
    Line line[num + 1];
    for(i = 1; i <= num; i++)
    {
        Line *l1, l2;
        l1->showCounter();
        l1->showSum();
        l1 = new Line(p, q);
        line[i].readLine();
        p.showCounter();
        p.showSum();
        delete l1;
        l2.showCounter();
        l2.showSum();
        q.showCounter();
        q.showSum();
    }
    Line l1(p, q), l2(p,t), l3(q,t), l4(l1);
    Line::showCounter();
    Line::showSum();
    Point::showCounter();
    Point::showSum();
    Line *l = new Line[num];
    l4.showCounter();
    l4.showSum();
    delete[] l;
    t.showCounter();
    t.showSum();
}

AC代码

#include <iostream>

using namespace std;
class Point
{
    friend class Line;
private:
    double _a,_b;
    static int sum,now;
public:
    Point():_a(0),_b(0){++sum,++now;}
    Point(double a,double b):_a(a),_b(b){++sum;++now;}
    Point(const Point& p):_a(p._a),_b(p._b){++sum;++now;}
    ~Point(){--now;}
//    double geta(){return _a;}
//    double getb(){return _b;}
    static void showCounter(){cout<<"Current : "<<now<<" points."<<endl;}
    static void showSum(){cout<<"In total : "<<sum<<" points."<<endl;}

};
int Point::sum=0;
int Point::now=0;
class Line
{
    friend class Point;
private:
    Point p1,p2;
    static int su,no;
public:
    Line():p1(0,0),p2(0,0){++su;++no;}
    Line(Point &p,Point &q):p1(p),p2(q){++su;++no;}//刚开始忘记加&号结果数据错了;
    void readLine(){char c;cin>>p1._a>>c>>p1._b>>p2._a>>c>>p2._b;}
    static void showCounter(){cout<<"Current : "<<no<<" lines."<<endl;}
    static void showSum(){cout<<"In total : "<<su<<" lines."<<endl;}
    ~Line(){--no;}
    Line(Line& p):p1(p.p1),p2(p.p2){++su;++no;}
};
int Line::su=0;
int Line::no=0;
int main()
{
    int num, i;
    Point p(1, -2), q(2, -1), t;
    t.showCounter();
    t.showSum();
    std::cin>>num;
    Line line[num + 1];
    for(i = 1; i <= num; i++)
    {
        Line *l1, l2;
        l1->showCounter();
        l1->showSum();
        l1 = new Line(p, q);
        line[i].readLine();
        p.showCounter();
        p.showSum();
        delete l1;
        l2.showCounter();
        l2.showSum();
        q.showCounter();
        q.showSum();
    }
    Line l1(p, q), l2(p,t), l3(q,t), l4(l1);
    Line::showCounter();
    Line::showSum();
    Point::showCounter();
    Point::showSum();
    Line *l = new Line[num];
    l4.showCounter();
    l4.showSum();
    delete[] l;
    t.showCounter();
    t.showSum();
}

注意:
1、在计数数字的时候,上下都可以是sum和now,因为类内定义的变量只属于这个类,虽然它是静态变量,存在全局数据区,但还是只归它所属的类。因此上面的sum和now只计数上面的类数目,下面的sum和now只计数下面的类数目,虽然名称相同,但是计数的个数和类型是不同的;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
和直线类(综合型题目) (1)创建C#控制台应用程序L4_1。 (2)在程序中新建一个点类CzPoint,为其定义两个double型的私有字段成员x和y,分别表示的横坐标和纵坐标。 (3)为CzPoint定义两个公有属性X、Y,分别用于封装对字段x和y的读写访问。 (4)定义CzPoint的带参数构造函数,在其中对字段x和y进行初始化。 (5)为CzPoint定义公有方法Move,用于按指定的水平距离和垂直距离移动坐标。 (6)对CzPoint进行相等和不相等操作符重载。两个坐标相等,是指它们的横坐标和纵坐标都相等。 (7)在程序主方法中创建两个坐标对象,判断它们是否相等;而后将第一个坐标移动到第二个坐标上,再判断它们是否相等。 (8)在程序中再新建一个直线类CzLine,为其定义两个double型的字段成员a 和b,分别表示直线的斜率和截距;再定义字段封装属性A和B,但它们都是只读的。 (9)为CzLine定义两个构造函数,一个根据斜率和截距来创建直线对象,另一个则根据两个CzPoint对象来构造直线对象(直线穿过这两个)。后一个的参考源代码如下(因涉及数学公式,故给出代码): public CzLine(CzPoint p1,CzPoint p2) { this.a=(p2.Y-p1.Y)/(p2.X-p1.X); this.b=p1.Y-this.a*p1.X; } (10)为CzLine定义公有方法Move,但它只用于平移直线,而不改变直线的斜率(即平移后的直线与原来的直线平行)。再为其定义公有方法Contains,用于判断某是否在该直线上。 (11)似的,为CzLine重载相等和不相等操作符。 (12)最后在程序主方法中采用不同的方式创建直线对象,并编译运行程序,测试它们的使用效果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值