计算机程序设计能力考试(Programming Ability Test,简称PAT)旨在通过统一组织的在线考试及自动评测方法客观地评判考生的算法设计与程序设计实现能力,科学的评价计算机程序设计人才,为企业选拔人才提供参考标准(网址http://www.patest.cn)。
每次考试会在若干个不同的考点同时举行,每个考点用局域网,产生本考点的成绩。考试结束后,各个考点的成绩将即刻汇总成一张总的排名表。
现在就请你写一个程序自动归并各个考点的成绩并生成总排名表。
输入格式:
输入的第一行给出一个正整数N(≤100),代表考点总数。随后给出N个考点的成绩,格式为:首先一行给出正整数K(≤300),代表该考点的考生总数;随后K行,每行给出1个考生的信息,包括考号(由13位整数字组成)和得分(为[0,100]区间内的整数),中间用空格分隔。
输出格式:
首先在第一行里输出考生总数。随后输出汇总的排名表,每个考生的信息占一行,顺序为:考号、最终排名、考点编号、在该考点的排名。其中考点按输入给出的顺序从1到N编号。考生的输出须按最终排名的非递减顺序输出,获得相同分数的考生应有相同名次,并按考号的递增顺序输出。
输入样例:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
输出样例:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
下面的网址提供了测试样例
https://blog.csdn.net/u012860063/article/details/41319063?utm_source=blogxgwz1
答案1
#include <bits/stdc++.h>
using namespace std;
struct S
{
string no;//编号;
int score;//成绩
int stand;//名次;
int sumsuand;//合起来的时候的名次
int spot;//考点;
} Student[30000];
int cmp1(S &a,S &b)
{
if(a.score==b.score)
{
return a.no<b.no;
}
else return a.score>b.score;
}
int main()
{
int N;
scanf("%d",&N);
int rec=0;
int sum=0;
for(int k=0; k<N; k++)
{
int flag=1,flag1=1;
rec+=1;
int n;
scanf("%d",&n);
for(int i=sum; i<sum+n; i++)
{
cin>>Student[i].no>>Student[i].score;
Student[i].spot=rec;
}
sort(Student+sum,Student+n+sum,cmp1);
Student[sum].stand=flag;
for(int i=sum+1; i<n+sum; i++)
{
flag+=1;
if(Student[i].score==Student[i-1].score)
{
Student[i].stand=Student[i-1].stand;
}
else
Student[i].stand=flag;
}
//for(int i=sum; i<sum+n; i++)
//{
// printf("%lld %d %d %d\n",Student[i].no,Student[i].sumsuand,Student[i].spot,Student[i].stand);
//}
sum+=n;
if(k==N-1)
{
sort(Student,Student+sum,cmp1);
Student[0].sumsuand=flag1;
for(int i=1; i<sum; i++)
{
flag1+=1;
if(Student[i].score==Student[i-1].score)
{
Student[i].sumsuand=Student[i-1].sumsuand;
}
else
Student[i].sumsuand=flag1;
}
printf("%d\n",sum);
for(int i=0; i<sum; i++)
{
cout<<Student[i].no;
printf(" %d %d %d\n",Student[i].sumsuand,Student[i].spot,Student[i].stand);
}
}
}
return 0;
}
答案2
#include <bits/stdc++.h>
using namespace std;
struct S
{
char no[17];//编号;
int score;//成绩
int stand;//名次;
int sumsuand;//合起来的时候的名次
int spot;//考点;
} Student[30000];
int cmp1(S &a,S &b)
{
if(a.score==b.score)
{
return strcmp(a.no,b.no)<0;
}
else return a.score>b.score;
}
int main()
{
int N;
scanf("%d",&N);
int rec=0;
int sum=0;
for(int k=0; k<N; k++)
{
int flag=1,flag1=1;
rec+=1;
int n;
scanf("%d",&n);
for(int i=sum; i<sum+n; i++)
{
cin>>Student[i].no>>Student[i].score;
Student[i].spot=rec;
}
sort(Student+sum,Student+n+sum,cmp1);
Student[sum].stand=flag;
for(int i=sum+1; i<n+sum; i++)
{
flag+=1;
if(Student[i].score==Student[i-1].score)
{
Student[i].stand=Student[i-1].stand;
}
else
Student[i].stand=flag;
}
//for(int i=sum; i<sum+n; i++)
//{
// printf("%lld %d %d %d\n",Student[i].no,Student[i].sumsuand,Student[i].spot,Student[i].stand);
//}
sum+=n;
if(k==N-1)
{
sort(Student,Student+sum,cmp1);
Student[0].sumsuand=flag1;
for(int i=1; i<sum; i++)
{
flag1+=1;
if(Student[i].score==Student[i-1].score)
{
Student[i].sumsuand=Student[i-1].sumsuand;
}
else
Student[i].sumsuand=flag1;
}
printf("%d\n",sum);
for(int i=0; i<sum; i++)
{
cout<<Student[i].no;
printf(" %d %d %d\n",Student[i].sumsuand,Student[i].spot,Student[i].stand);
}
}
}
return 0;
}
注意:
1、读清题目,题目中要求的是,如果两者分数相等的话,一句编号排名
2、编号不能使用longlong类型的,因为如果编号前面有0的话不能保存
3、string和char[]类型注意好区别
一、string
1、string是c++中新增成员,在C语言中是没有string的。
二、string与char[]之间的比较
1、如何读取问题
(1)对于string来说,只能用cin读入,只能通过cout输出,不能用scanf读入,printf输出。
(2)char[]可以用cin,也可以用scanf,可以用cout,也可以用printf
2、读取快慢问题
(1)string读入的比较慢,输出会耗费比较多的时间
(2)char[]比较快
3、赋值方式
(1)string赋值方式
string a,b;
a=b;
(2)char*赋值方式
cahr a[100],b[100];
strcpy(a,b);//把b拷贝到a中;
4、比较大小的方式
(1)string比较大小的方式
- 可以用以下运算符进行比较 == ,!= ,<,<=,>,>= 。并且,区分大小写,规则如下
- 根据长度不同时,如果对应位置字符相同时,较长的大于较短的
- 如果对应位置不同时,直接比较第一个不同字符的结果
a>b;
a=b;
a<b;
(2)char[]比较大小
strcmp(注意:string类型的不能用strcmp进行比较)
strcmp函数介绍:
(1)作用:用来比较字符串的大小
(2)比较机制:
- 如果字符串1的第n位的ASCII码值等于字符串2的第n位的ASCII码值则继续比较下一位
- 如果字符串1的第n位的ASCII码值大于字符串2的第n位的ASCII码值则输出结果:1 表示字符串1 >字符串2(实际上返回值应该是字符串1的ASCII值-字符串2的ASCII值)
- 如果字符串1的第n位的ASCII码值小于字符串2的第n位的ASCII码值则输出结果:-1 表示字符串1 >字符串2(实际上返回值应该是字符串1的ASCII值-字符串2的ASCII值)
也就是说相应位置上的差值为0的话,继续比较;如果差值大于0的话,返回该大于0的数;如果差值小于0的话,返回该小于0的数。
三、结构体
https://blog.csdn.net/fighting123678/article/details/82959776
四、sort函数
https://blog.csdn.net/shirley3052004/article/details/72896815
sort(起始地址,终止地址,排序方式);
注意:
1、在自己所写的函数中,return什么,就代表一什么的方式进行排序