A water problem HDU - 5832

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days NN after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input

There are several test cases(about 55 huge test cases).

For each test, we have a line with an only integer N(0≤N)N(0≤N), the length of NN is up to 10000000.

Output

For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

Sample Input

10001
0
333

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

A water problem题目·很明确,一道水题.但抱歉的是高精度取余我懂,所以经不断的哇.10^10000000的数,所以是一定要用高精度取余的.

AC代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<vector>
using namespace std;
int a = 0;
const int maxn = 10000010;
char ch[maxn];
int main()
{
	while (~scanf("%s", ch))
	{
		a++;
		printf("Case #%d: ", a);
		int t1, t2, sum1,sum2;
		sum1 = ch[0] - '0';
		sum2 = sum1;
		int len = strlen(ch);
		for (int i = 1; i < len; i++)
		{
			t1 = (sum1*10 + ch[i] - '0') % 73;
			t2 = (sum2*10 + ch[i] - '0') % 73;
			sum1 = t1;
			sum2 = t2;
		}
		if (sum1 == 0 && sum2 == 0)
		{
			printf("YES\n");
		}
		else
		{
			printf("NO\n");
		}

	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值