hdu 4737 A Bit Fun o(30*n)

A Bit Fun

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2092    Accepted Submission(s): 1040


Problem Description
There are n numbers in a array, as a 0, a 1 ... , a n-1, and another number m. We define a function f(i, j) = a i|a i+1|a i+2| ... | a j . Where "|" is the bit-OR operation. (i <= j)
The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.
 

Input
The first line has a number T (T <= 50) , indicating the number of test cases.
For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 2 30) Then n numbers come in the second line which is the array a, where 1 <= a i <= 2 30.
 

Output
For every case, you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1.
Then follows the answer.
 

Sample Input
  
  
2 3 6 1 3 5 2 4 5 4
 

Sample Output
  
  
Case #1: 4 Case #2: 0

两个指针tail,top 如果这个区间内的或值小于m答案增加tail-top+1

否则top++,

用dp数组保存某个区间的数字,第i位一共有几个1,把dp变成10进制数后就可以跟m比较大小了


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ll long long
#define uint  int
uint dp[32];
uint num[100007];
uint value(){
    uint x = 0;
    for(int i = 0;i < 30;i++){
        if(dp[i]) x |= 1<<i;
    }
    return x;
}
int main(){
    int t,tt=1;
    scanf("%d",&t);
    int n;
    uint m;
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i = 0;i < n; i++)
            scanf("%d",&num[i]);
        memset(dp,0,sizeof(dp));
        ll ans = 0;
        int top = 0,tail = 0,a,i,b,c;
        while(tail < n){
            if(num[tail] >= m){
                top = tail+1;
                memset(dp,0,sizeof(dp));
            }
            else {
                a = num[tail],i=0;
                while(a) dp[i++]+=a&1,a>>=1;
                while(value() >= m && top <= tail){
                    a = num[top++],i=0;
                    while(a) dp[i++]-=a&1,a>>=1;
                }
            }
            ans += (tail-top+1);
            tail++;
        }
        printf("Case #%d: %I64d\n",tt++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值