问题 E: Shortest Distance (20)

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 10 5 ]), followed by N integer distances D 1  D 2  ... D N , where D i  is the distance between the i-th and the (i+1)-st exits, and D N  is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=10 4 ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10 7 .

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出

3
10
7

此题主要难点在于控制好时间复杂度,若在输入每个数字对再去数组中逐一遍历分别计算顺时针和逆时针的和取其最小值,需要多个for循环遍历,若n的规模过大则无法在短时内解决此问题。

书中提供的思路的妙处在于在输入数组时就预先进行计算,将每一个元素到第一个元素之间的和计算出来存入数组。在输入数字对进行结果计算时,仅需取出预先处理好的数组中的数据作差即可。

这种思路同样体现了牺牲空间复杂度来提高时间复杂度的思想。在本文最后还附上了自己之前写的时间复杂度过高的程序代码,可从中汲取教训。

#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
	const int Nmax=100005;
	int dis[Nmax],a[Nmax],n,m,sum=0;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",a+i);
		dis[i]=sum;
		sum+=a[i];
	}
	scanf("%d",&m);
	for(int i=0;i<m;i++){
		int x,y,ahead=0,back=0;
		scanf("%d%d",&x,&y);
		if(x>y)swap(x,y);
		ahead+=(dis[y-1]-dis[x-1]);
		back+=(sum-dis[y-1]+dis[x-1]);
		if(ahead>back)printf("%d\n",back);
		else printf("%d\n",ahead);
	}
	return 0;
}

时间复杂度过大的算法如下:

#include<cstdio>
int main(){
	int n,a[100000];
	scanf("%d",&n);
	for(int i=0;i<n;i++)scanf("%d",a+i);
	int m,b,c,sum_ahead=0,sum_back=0;
	scanf("%d",&m);
	for(int i=0;i<m;i++){
		scanf("%d%d",&b,&c);
		if(((c+n-b)%n)<(n-(c+n-b)%n)){
			for(int j=0,k=b-1;j<(c+n-b)%n;j++){
				sum_ahead+=a[k];
				k++;
				if(k==n)k=0;
			}
			for(int j=0,k=b-1;j<n-(c+n-b)%n;j++){
				k--;
				if(k==-1)k=n-1;
				sum_back+=a[k];
				if(sum_back>sum_ahead){
					printf("%d\n",sum_ahead);
					break;
				}
			}
			if(sum_back<sum_ahead)printf("%d\n",sum_back);
		}else{
			for(int j=0,k=b-1;j<n-(c+n-b)%n;j++){
				k--;
				if(k==-1)k=n-1;
				sum_back+=a[k];					
			}
			for(int j=0,k=b-1;j<(c+n-b)%n;j++){
				sum_ahead+=a[k];
				k++;
				if(k==n)k=0;
				if(sum_ahead>sum_back){
					printf("%d\n",sum_back);
					break;
				}
			}
			if(sum_ahead<sum_back)printf("%d\n",sum_ahead);
		}						
		sum_back=0;
		sum_ahead=0;
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值