问题描述:
The Recaman's sequence is defined by a0 = 0 ; for m > 0, am = am-1 - m if the rsulting am is positive and not already in the sequence, otherwise am = am-1 + m.
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9... . Given k, your task is to calculate ak.
Input
The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. The last line contains an integer -1, which should not be processed.
Output
For each k given in the input, print one line containing ak to the output.
Sample Input
7
10000
-1
Sample Output
20
18658
#include <iostream>
#include <cstdio>
#include <map>
using namespace std;
long s[500005];
map<long ,bool>hash;
void init()
{
long i,t;
s[0] = 0;
hash.clear();
hash[0]=1;
for(i=1; i<500003; i++)
{
t = s[i-1]-i;
if(t<=0 || hash[t])
s[i] = s[i-1]+i;
else
s[i] = t;
hash[s[i]] = true;
}
}
int main()
{
int p;
freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
init();
while(cin>>p && p!=-1)
cout<<s[p]<<endl;
return 0;
}