poj 3009 Curling 2.0——dfs

Curling 2.0

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

在这里插入图片描述

Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), ©).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.
在这里插入图片描述

Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

在这里插入图片描述

Fig. 3: The solution for Fig. D-1 and the final board configuration
Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output
1
4
-1
4
10
-1

题意: 类似走迷宫,从起点选择一个出发,不撞南墙不会停,被撞的那幢墙一幢就倒下了,而此时走迷宫者也停在了被撞倒的南墙前面一格。然后又重新选择方向出发,只能走东南西北四个方向,不能走斜。问能不能在10步内(包含10步)从起点走到终点。如果能,输出最少需要走的步数,如果不能输出 -1。

题解: 第一反应想到了bfs,因为是一个找最短路径的问题,后来发现它图里面的状态会变化,用bfs根本就很复杂。果断放弃思考,直接在网上搜题解。

  这里应该得用dfs,每次到达终点都与之前到达所需要的步数进行比较一次,如果比之前到达终点的步数少,则更新。如果最终的总步数超过了10,则输出-1。详细逻辑见代码。

#include<cstdio>
#include<cstdlib>
#define size 30

int H,W;
int result;
int Graph[size][size];
int sx,sy,ex,ey;
const int dx[5] = {1,0,-1,0};    // 表示4个方向的数组
const int dy[5] = {0,1,0,-1};

void dfs(int ,int, int);
bool in_map(int ,int);

int main()
{
    while(scanf("%d%d",&W,&H) && (W+H))
    {
        for(int i=0;i<H;i++)        // 初始化图
            for(int j=0;j<W;j++)
                scanf("%d",&Graph[i][j]);

        result = 11;
        for(int i=0;i<H;i++)        // 找出起点和终点
            for(int j=0;j<W;j++){
                if(Graph[i][j] == 2){
                    sx = i;
                    sy = j;
                    Graph[i][j] = 0;        // 将起点值设置为可走
                }
                if(Graph[i][j] == 3){
                    ex = i;
                    ey = j;
                }
            }
        dfs(sx,sy,0);
        if(result == 11)
            puts("-1");
        else
            printf("%d\n",result);
    }
    system("pause");
    return 0;
}

void dfs(int x,int y,int step)
{
    if (x == ex && y == ey) {
        if(result > step)
            result = step;
        return ;
    }

    // 如果步数达到10步或者是比已经求出的最短的路还要长,返回
    if(step == 10 || step >= result) return;

    for(int i=0;i<4;i++) {
        int xi = x + dx[i];
        int yi = y + dy[i];
        // 在该方向上一直前进,直到碰壁或者出界
        while(in_map(xi,yi) && Graph[xi][yi] != 1) {
            if(xi == ex && yi == ey) {
                step++;
                if(result > step)
                    result = step;
                return ;
            }
            xi += dx[i];
            yi += dy[i];
        }

        // 如果当前走的这一步是墙壁或者是出界,换另外一个方向走
        if(xi == x + dx[i] && yi == y + dy[i] || !in_map(xi,yi)) continue;

        // 碰壁的位置变为0
        Graph[xi][yi] = 0;
        dfs(xi - dx[i],yi - dy[i],step+1);
        // 退出该层递归,将原地图还原
        Graph[xi][yi] = 1;
    }
}

bool in_map(int x,int y)
{
    return 0 <= x && x < H && 0 <= y && y < W;
}

代码参考自:https://www.cnblogs.com/7hat/p/3592080.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值