POJ3009 Curling 2.0 (DFS)

23 篇文章 0 订阅
9 篇文章 0 订阅

Curling 2.0
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21478 Accepted: 8754

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Source


思路:题目让求得是从出发点到目标点的最小步数,即2——>3的最小步数,当要走的下一方向是空白处,即0的时候,可以继续往前走,当要走的下一方向会出界时,则不能够走这个方向,当要走的下一方向是障碍物时,即1的时候,则把1变成0,停止下来,再走另一步。当步数大于10的时候,则不符合题意。

AC代码如下:

#include <cstdio>
#include <cstring>
#define INF 0x3f3f3f3f
using namespace std;

const int MAX_N = 25;
int w,h,endx,endy;
int map[MAX_N][MAX_N],steps;
int dir[4][2] = {-1,0,1,0,0,1,0,-1},count;

void dfs(int x, int y){

	if(steps >= 10)//步数要小于等于10,因下面有steps++,故此处加= 
		return ;
	
	for(int i = 0; i < 4; i ++){
		int dx = x,dy = y;
		
		while(1){
			dx = dx + dir[i][0];		dy = dy + dir[i][1];//按照这个方向一直走 
			if(dx < 0 || dx >= h || dy < 0 || dy >= w)//出界 
				break;
			if(dx == endx && dy == endy){//走到目标点 
				steps ++;
				if(count > steps)//取最优的步数 
					count = steps;
				steps --;//还原步数 
				return ;
			}
			else if(map[dx][dy] == 1){//当前为障碍 
				if(dx - dir[i][0] != x || dy - dir[i][1] != y){//判断是否是出发点的下一个方向就是障碍 
					map[dx][dy] = 0;//变成空白处 
					steps ++;//步数加1 
					dfs(dx - dir[i][0],dy - dir[i][1]);
					map[dx][dy] = 1;//还原 
					steps --;
				}	
				break;
			}
		}	
	}
	return ;
}

int main(){
	while(~scanf("%d%d",&w,&h)){
		if(!w && !h)
			break;
		int startx,starty;
		
		for(int i = 0; i < h; i ++){
			for(int j = 0; j < w; j ++){
				scanf("%d",&map[i][j]);
				if(map[i][j] == 2){
					startx = i;		starty = j;
				}
				else if(map[i][j] == 3){
					endx = i; 	endy = j;
				}
			}
		}
		count = INF;
		steps = 0;
		dfs(startx,starty);
		if(count == INF)
			printf("-1\n");
		else
			printf("%d\n",count);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值