堆优化Dijkstra求最短路

时间复杂度 O(mlogn), n 表示点数,m 表示边数,适合稀疏图,用邻接表存储

在这里插入图片描述
模板

typedef pair<int, int> PII;

int n;      // 点的数量
int h[N], w[N], e[N], ne[N], idx;       // 邻接表存储所有边
int dist[N];        // 存储所有点到1号点的距离
bool st[N];     // 存储每个点的最短距离是否已确定

// 求1号点到n号点的最短距离,如果不存在,则返回-1
int dijkstra()
{
    memset(dist, 0x3f, sizeof dist);
    dist[1] = 0;
    priority_queue<PII, vector<PII>, greater<PII>> heap;
    heap.push({0, 1});      // first存储距离,second存储节点编号

    while (heap.size())
    {
        auto t = heap.top();
        heap.pop();

        int ver = t.second, distance = t.first;

        if (st[ver]) continue;
        st[ver] = true;

        for (int i = h[ver]; i != -1; i = ne[i])
        {
            int j = e[i];
            if (dist[j] > distance + w[i])
            {
                dist[j] = distance + w[i];
                heap.push({dist[j], j});
            }
        }
    }

    if (dist[n] == 0x3f3f3f3f) return -1;
    return dist[n];
}


例题

850. Dijkstra求最短路 II

给定一个n个点m条边的有向图,图中可能存在重边和自环,所有边权均为非负值。

请你求出1号点到n号点的最短距离,如果无法从1号点走到n号点,则输出-1。
输入格式

第一行包含整数n和m。

接下来m行每行包含三个整数x,y,z,表示存在一条从点x到点y的有向边,边长为z。
输出格式

输出一个整数,表示1号点到n号点的最短距离。

如果路径不存在,则输出-1。
数据范围

1≤n,m≤1.5×10^5,
图中涉及边长均不小于0,且不超过10000。
输入样例:

3 3
1 2 2
2 3 1
1 3 4

输出样例:

3

代码

#include <iostream>
#include <queue>
#include <algorithm>
#include <cstring>

using namespace std;

typedef pair<int,int> PII;
const int N = 150010;

int h[N],ne[N],e[N],w[N],idx;

int dist[N];
bool st[N];

int n,m;
int x,y,z;


void add(int a,int b,int c);
int dijkstra();

int main(){
    
    memset(h, -1, sizeof h);
    
    cin>>n>>m;
    while(m--){
        scanf("%d%d%d",&x,&y,&z);
        add(x,y,z);
    }
    
    cout<<dijkstra()<<endl;
    return 0;
    
}

// a到b节点之间长为c
void add(int a,int b,int c){
    
    e[idx] = b;
    w[idx] = c;
    ne[idx] = h[a];
    h[a] = idx++;
}

int dijkstra(){
    
    memset(dist,0x3f,sizeof dist);
    
    priority_queue<PII,vector<PII>, greater<PII> > hash;
    hash.push({0,1});
    dist[1] = 0;
    
    while(!hash.empty()){
        auto t = hash.top();
        hash.pop();
        
        int ver = t.second, distance = t.first;
        
        if(st[ver])
            continue;
        st[ver] = true;
        //更新
        for(int i = h[ver]; i != -1; i = ne[i]){
            int j = e[i];
            if(w[i] + distance < dist[j] ){
                 dist[j] = w[i] + distance;
                 hash.push({dist[j],j});
            }
               
        }
    }
    
    
    if(dist[n] == 0x3f3f3f3f)
        return -1;
    return dist[n];
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值