ASCII
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 735 Accepted Submission(s): 324
Problem Description
Since all we know the ASCII code, your job is simple: input numbers and output corresponding messages.
Input
The first line contains one integer T (1<=T<=1000).
The input will contain T positive integers separated by whitespaces (spaces, newlines, TABs).
The integers will be no less than 32.
The input will contain T positive integers separated by whitespaces (spaces, newlines, TABs).
The integers will be no less than 32.
Output
Output the corresponding message in just one line.
Warning: no extra characters are allowed.
Warning: no extra characters are allowed.
Sample Input
13 72 101 108 108 111 44 32 119 111 114 108 100 33
Sample Output
Hello, world!
就一个案例!Notice!
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
int cases, i;
char c[1001];
while (scanf("%d",&cases)!=EOF)
{
memset(c, 0, sizeof(c));
for (i=0; i<cases; i++)
{
scanf("%d",&c[i]);
}
for (i=0; i<cases; i++)
{
printf("%c",c[i]);
}
}
return 0;
}