ACMSTEP 1.2.6 ASCII//超级水题

ASCII

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 735 Accepted Submission(s): 324
Problem Description
Since all we know the ASCII code, your job is simple: input numbers and output corresponding messages.

Input
The first line contains one integer T (1<=T<=1000).
The input will contain T positive integers separated by whitespaces (spaces, newlines, TABs).
The integers will be no less than 32.

Output
Output the corresponding message in just one line.
Warning: no extra characters are allowed.

Sample Input
13
72 101 108 108 111 44
32 119 111 114 108 100 33

Sample Output
Hello, world!


就一个案例!Notice!

#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
	int cases, i;
	char c[1001];
	while (scanf("%d",&cases)!=EOF)
	{
		memset(c, 0, sizeof(c));
		for (i=0; i<cases; i++)
		{
			scanf("%d",&c[i]);
		}
		for (i=0; i<cases; i++)
		{
			printf("%c",c[i]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值