Max Sequence

Max Sequence

Time Limit : 6000/3000ms (Java/Other) Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 3 Accepted Submission(s) : 3
Problem Description
Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N).

You should output S.

Input
The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.

Output
For each test of the input, print a line containing S.

Sample Input
  
  
5 -5 9 -5 11 20 0

Sample Output
  
  
40

#include<iostream>
using namespace std;
int main(int ac,char *av[])
{
    int cases;
    while(cin>>cases,cases)
    {
        int i,tmp,sum=0,max_v=-999999,arr[100002],dp[100002];
        for(i=0;i<cases;i++)
        {
            cin>>tmp;
            arr[i+1]=tmp;
            sum+=tmp;
            if(sum>max_v)
            max_v=sum;
            if(sum<0)
            sum=0;
            dp[i+1]=max_v;
        }
        sum=0,max_v=-999999;
        for(i=cases;i>1;i--)
        {
         sum+=arr[i];
         if(sum+dp[i-1]>max_v)
         max_v=sum+dp[i-1];
         if(sum<0)
         sum=0;

        }
        cout<<max_v<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值