Dragon Balls (并查集)

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
题意:先说每个城市和龙珠都有编号
,对应的第i个龙珠放在第i个城市。T A B表示把A号龙珠所在的
城市的所有龙珠全部搬运到B号龙珠所在的城市。 Q A表示要求出
X(第A号龙珠所在的城市编号),Y(第X号城市存放的龙珠个数)
,Z(第A号龙珠被搬运的次数)。题解: 不管怎样搬运龙珠,
拥有龙珠的城市必然有一个和城市编号相对应的龙珠,因此可以将
其作为父节点(龙珠所在城市编号)。根据题意无论哪个节点移动时,
都是整棵树移动,所以直接可以用一个数组citynum[]表示城市存放的龙
珠数,tranum[]表示龙珠移动的次数。

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxm = 10005;
int a[maxm];
int citynum[maxm];//记录每个城市的龙珠个数 
int transnum[maxm];//记录每个龙珠移动的次数 

int find(int x)
{
	//if (a[x]==x)
	//	return x;
	if (x!=a[x])
	{
		int t = a[x];
		a[x] = find(a[x]); 
		transnum[x] += transnum[t];//加上父节点的移动次数的次数 
	//	return a[x];
	}
	return a[x];
}

void unite(int x,int y)
{
	x = find(x);
	y = find(y);
	if (x==y)
		return;
	else
	{
		a[x] = y;
		citynum[y] += citynum[x];//把子节点的龙珠全部给父节点
		transnum[x]++;//转移次数加一 
	}
}

int main()
{
	int t,k;
	scanf("%d",&t);
	for (k=1;k<=t;k++)
	{
		char s[3];
		int n,q,i;
		scanf("%d %d",&n,&q);
		for (i=1;i<=n;i++)
		{
			a[i] = i;
			citynum[i] = 1;
			transnum[i] = 0;
		}
		printf("Case %d:\n",k);
		for (i=0;i<q;i++)
		{
			scanf("%s",s);
			if (s[0]=='T')
			{
				int x,y;
				scanf("%d %d",&x,&y);
				unite(x,y);
			}
			else
			{
				int x;
				scanf("%d",&x);
				int m = find(x);
				printf("%d %d %d\n",m,citynum[m],transnum[x]);
			}
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值