Dragon Balls [并查集]

Five hundred years later, the number of dragon balls will increase unexpectedly, so it’s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities’ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
题意描述:

有n个龙珠散落在n个城市,编号1-n;有m组行动,‘T’为将城市a的龙珠运输到城市b中,‘Q’为询问编号为x的龙珠现在在哪个城市,这个城市现在有多少个龙珠,编号为x的龙珠被运输了多少次。输出每次询问的结果。

/*
刚开始所有龙珠的父亲节点都是本身
将一个龙珠移动到另外的一个城市意味着更改这个龙珠的父亲节点为另外一个城市
查询该龙珠在哪个城市就是输出他的父亲节点
查询该城市有多少个龙珠就是遍历所有龙珠找到以该城市为父亲节点的所有龙珠并计数
这个会超时
直接在join函数中把子节点的数量加到父亲节点中 

*/
#include <stdio.h>
#include <string.h>

const int MAXN = 1e4 + 10;

int f[MAXN], cnt[MAXN], num[MAXN];

int find (int x) {
    if ( x == f[x])
        return x;
    int tmp = f[x];
    f[x] = find(tmp);
    cnt[x] += cnt[tmp]; // 他的移动次数就是他自己加上 
    return f[x];        //他的父亲节点的次数 
}

void join (int x, int y) {
    int fx = find (x);
    int fy = find (y);
    if (fx != fy) {
        f[f[x]] = fy;
        num[fy] += num[fx];
        cnt[fx] = 1; // 这里是他的父节点移动一次 
    }
}

int main () {
    int T, Case = 1;
    scanf ("%d", &T);
    while (T --) {
        for (int i = 0; i <= MAXN; i++) {
            f[i] = i; num[i] = 1; cnt[i] = 0;
        }
        int N, Q;
        scanf ("%d %d", &N, &Q);
        printf ("Case %d:\n", Case++);
        while (Q --) {
            char str[10];
            int x1, x2;
            scanf ("%s %d", str, &x1);
            if (str[0] == 'T') {
                scanf ("%d", &x2);
                join (x1, x2);
            }
            else {
                int city = find(x1);
                printf ("%d %d %d\n", city, num[city], cnt[x1]);
            }
        } 
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值