As Easy As A+B
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24266 Accepted Submission(s): 10230
Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.
It is guarantied that all integers are in the range of 32-int.
Output
For each case, print the sorting result, and one line one case.
Sample Input
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
Sample Output
1 2 3 1 2 3 4 5 6 7 8 9
Author
lcy
kao....每行都有换行,每行最后没有空格
#include<iostream>
#include<algorithm>
using namespace std;
int num[1001];
int main()
{
int n,tn;
cin>>n;
while(n--)
{
cin>>tn;
for(int i=0;i<tn;i++)
{
cin>>num[i];
}
sort(num,num+tn);
for(int i=0;i<tn-1;i++)
cout<<num[i]<<" ";
cout<<num[tn-1];
cout<<endl;
}
return 0;
}