1015 德才论 (25分) PAT Java代码实现 牛客AC

1015 德才论 (25分)

宋代史学家司马光在《资治通鉴》中有一段著名的“德才论”:“是故才德全尽谓之圣人,才德兼亡谓之愚人,德胜才谓之君子,才胜德谓之小人。凡取人之术,苟不得圣人,君子而与之,与其得小人,不若得愚人。”

现给出一批考生的德才分数,请根据司马光的理论给出录取排名。

输入格式:

输入第一行给出 3 个正整数,分别为:N(≤ 1 0 5 10^{5} 105​​ ),即考生总数;L(≥60),为录取最低分数线,即德分和才分均不低于 L 的考生才有资格被考虑录取;H(<100),为优先录取线——德分和才分均不低于此线的被定义为“才德全尽”,此类考生按德才总分从高到低排序;才分不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;德才分均低于 H,但是德分不低于才分的考生属于“才德兼亡”但尚有“德胜才”者,按总分排序,但排在第二类考生之后;其他达到最低线 L 的考生也按总分排序,但排在第三类考生之后。

随后 N 行,每行给出一位考生的信息,包括:准考证号 德分 才分,其中准考证号为 8 位整数,德才分为区间 [0, 100] 内的整数。数字间以空格分隔。

输出格式:

输出第一行首先给出达到最低分数线的考生人数 M,随后 M 行,每行按照输入格式输出一位考生的信息,考生按输入中说明的规则从高到低排序。当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出。

输入样例:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

输出样例:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

解题思路:

此题犯了好长时间才来做,题目太长,描述太绕,感觉没意义。
题目考察点在于给定的数据按照要求排序。Java运行速度较慢,所以本题在PAT提交会运行超时,牛客上宽松一些,AC了。
重要的是学习解题技巧,我刚看完第一想法是用list.sort()来排序,其中按照表达式写排序规则。

在这里插入图片描述

代码实现:

具体逻辑处理看代码注释

import java.util.*;
import java.util.stream.Collectors;

public class Main {
    //定义一个类存储考生考号分数等信息
    public static class Person implements Comparable<Person>{
        //准考证号
        private int number;
        //德分
        private int dScore;
        //才分
        private int cScore;
        //总分
        private int total;

        private Person(int number, int dScore, int cScore){
            this.number = number;
            this.dScore = dScore;
            this.cScore = cScore;
            //总分为 德分+才分
            total = dScore + cScore;
        }
        @Override
        public int compareTo(Person o) {
            if(o.total - this.total != 0){
                return o.total - this.total;
            }else if(o.dScore - this.dScore != 0){
                return o.dScore - this.dScore;
            }else{
                return this.cScore - o.cScore;
            }
        }
    }

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        //考生数量
        int n = sc.nextInt();
        //录取最低分数线
        int l = sc.nextInt();
        //优先录取线
        int h = sc.nextInt();
        //存储输入的考生对象信息
        List<Person> list = new ArrayList<>();
        //读取考生信息
        while(n-- != 0){
            //赋值
            list.add(new Person(sc.nextInt(),sc.nextInt(),sc.nextInt()));
        }
        sc.close();
        //先过滤掉dScore或者cScore在录取最低分数线下的考生
        list = list.stream().filter(v->v.cScore >= l && v.dScore >= l).collect(Collectors.toList());
        //按规则排序  第一类 dScore和cScore均高于h  按照总分降序
        List<Person> one = new ArrayList<>();
        List<Person> two = new ArrayList<>();
        List<Person> three = new ArrayList<>();
        //dScore和cScore均高于l 低于h
        List<Person> four = new ArrayList<>();
        //筛出不同类别按照给定规则排序
        for(Person p : list){
            //才德全尽
            if(p.dScore >= h && p.cScore >= h){
                one.add(p);
            }else if(p.dScore >= h &&  p.cScore < h){
                //德胜才
                two.add(p);
            }else if(p.dScore <= h && p.cScore <=h && p.dScore >= p.cScore){
                //“才德兼亡”但尚有“德胜才”者
                three.add(p);
            }else{
                four.add(p);
            }
        }
        //排序
        Collections.sort(one);
        Collections.sort(two);
        Collections.sort(three);
        Collections.sort(four);
        //总计
        System.out.println(one.size()+two.size()+three.size()+four.size());
        //按照格式输出
        for(int x = 0; x < one.size(); x++){
            System.out.println(one.get(x).number + " " +one.get(x).dScore + " " + one.get(x).cScore);
        }
        for(int x = 0; x < two.size(); x++){
            System.out.println(two.get(x).number + " " + two.get(x).dScore + " " + two.get(x).cScore);
        }
        for(int x = 0; x < three.size(); x++){
            System.out.println(three.get(x).number + " " + three.get(x).dScore + " " + three.get(x).cScore);
        }
        for(int x = 0; x < four.size(); x++){
            System.out.println(four.get(x).number + " " + four.get(x).dScore + " " + four.get(x).cScore);
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值