PAT(A) - 1023. Have Fun with Numbers (20)


Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798


#include <cstdio>
#include <string.h>

using namespace std;

#define MAX 22

int main() {
    int num1[MAX] = { 0 };
    int num2[MAX] = { 0 };
    int count1[10] = { 0 };
    int count2[10] = { 0 };

    char str[MAX];
    gets( str );

    int len = strlen( str );
    for( int i = 0; i < len; i++ ) {
        num1[MAX - 1- i] = str[len - 1 - i] - '0';
        count1[num1[MAX - 1 - i]]++;
    }
/*
    for( int i = 0; i < MAX; i++ ) {
        printf( "%d", num1[i] );
    }
    printf( "\n" );
*/

    int r = 0;
    for( int i = MAX - 1; i >= 0; i-- ) {
        int n = num1[i] * 2 + r;
        r = n / 10;
        num2[i] = n % 10;
    }
/*
    for( int i = 0; i < MAX; i++ ) {
        printf( "%d", num2[i] );
    }
    printf( "\n" );
*/
    int zero_index = 0;
    while( num2[zero_index] == 0 ) {
        zero_index++;
    }

    for( int i = zero_index; i < MAX; i++ ) {
        count2[num2[i]]++;
    }
/*
    for( int i = 0; i < 10; i++ ) {
        printf( "%d : %d %d\n", i, count1[i], count2[i] );
    }
*/
    bool flag = true;
    for( int i = 0; i < 10; i++ ) {
        if( count1[i] == count2[i] && count1[i] == 0 ) {
            continue;
        }
        if( count1[i] != count2[i] ) {
            flag = false;
        }

    }

    if( flag ) {
        printf( "Yes\n" );
    }
    else {
        printf( "No\n" );
    }

    for( int i = zero_index; i < MAX; i++ ) {
        printf( "%d", num2[i] );
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值