PAT(A) - 1063. Set Similarity (25)


Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%


思路分析:考查使用STL,我刚开始用的模拟,新建立一个集合用来存两个集合的并集,然后再依次统计,结果最后一个测试点超时。。。其实直接统计两个集合的个数coutA+ countB,然后再计算交集的个数count,最后计算公式 ( count ) / ( countA + countB - count ), 就OK了,即使是这样最后一个测试点也险些超时,见别人有用map做的,我还没尝试。


#include <cstdio>
#include <set>

#define MAX 51
using namespace std;

int main() {
    //freopen( "123.txt", "r", stdin );
    set<int> s[MAX];
    int n;
    scanf( "%d", &n );

    for( int i = 1; i <= n; i++ ) {
        int m;
        scanf( "%d", &m );
        for( int j = 1; j <= m; j++ ) {
            int num;
            scanf( "%d", &num );
            s[i].insert( num );
        }
    }

    int k;
    scanf( "%d", &k );

    for( int i = 1; i <= k; i++ ) {
        int a, b;
        set<int>::iterator it; //定义前向迭代器
        scanf( "%d%d", &a, &b );

        int countA = s[a].size();
        int countB = s[b].size();

        double dis = 0.0;
        int count = 0;
        for( it = s[a].begin(); it != s[a].end(); it++ ) {
            if( s[a].find( *it ) != s[a].end() && s[b].find( *it ) != s[b].end() ) {
                count++;
            }
        }
        dis = (double)count / (double)( countA + countB - count );
        printf( "%.1lf%%\n", dis * 100.0 );
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值