PAT(A) - 1102. Invert a Binary Tree (25)

22 篇文章 0 订阅


1102. Invert a Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
 

思路分析:输入结点建立一棵二叉树,关键先找到根节点,然后进行遍历。输出第一行是层序遍历,第二行是中序遍历。然而。。。输出结果怎么和样例不太一样呢。原来还有一个单词是'Invert",意思是翻转。不用真正的做翻转,只要遍历的时候调整一下顺序就OK了。

#include <cstdio>
#include <queue>

#define MAX 10

using namespace std;

typedef struct {
    int index;
    int lchild;
    int rchild;
} Node;

Node node[MAX];
int count = 0;

void dfsInOrder( Node curNode ) {
    if( curNode.rchild != -1 ) {
        dfsInOrder( node[curNode.rchild] );
    }
    if( count == 0 ) {
       printf( "%d", curNode.index );
       count = 1;
    }
    else {
       printf( " %d", curNode.index );
    }
    if( curNode.lchild != -1 ) {
        dfsInOrder( node[curNode.lchild] );
    }

}

int main() {
    //freopen( "123.txt", "r", stdin );
    int isRoot[MAX] = { 0 };
    int n;
    scanf( "%d", &n );
    char ch = getchar();

    for( int i = 0; i < n; i++ ) {
        node[i].index = i;
        char left, right;
        scanf( "%c %c", &left, &right );
        char ch = getchar();

        if( left == '-' ) node[i].lchild = -1;
        else { node[i].lchild = left - '0'; isRoot[left - '0'] = 1; }

        if( right == '-' ) node[i].rchild = -1;
        else { node[i].rchild = right - '0'; isRoot[right - '0'] = 1; }
    }

    //for( int i = 0; i < n; i++ ) {
    //    printf( "%d %d %d\n", node[i].index, node[i].lchild, node[i].rchild );
    //}
    int root = 0;
    for( int i = 0; i < n; i++ ) {
        if( isRoot[i] == 0 ) {
           root = i;
           break;
        }
    }

    //printf( "root: %d\n", root );

    queue<Node> q;
    q.push( node[root] );

    while( !q.empty() ) {
        Node curNode = q.front();
        q.pop();
        if( count == 0 ) {
            printf( "%d", curNode.index );
            count = 1;
        }
        else
            printf( " %d", curNode.index );
        if( curNode.rchild != -1 ) q.push( node[curNode.rchild] );
        if( curNode.lchild != -1 ) q.push( node[curNode.lchild] );
    }
    printf( "\n" );

    count = 0;
    dfsInOrder( node[root] );

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值