PAT(A) - 1064. Complete Binary Search Tree (30)

22 篇文章 0 订阅


1064. Complete Binary Search Tree (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4

思路分析:题目要求是完全二叉树,这就很容易实现了!完全二叉树的结点i如果从1开始编号,那么左儿子为2*i,右儿子为2*i+1;而二叉搜索树的中序遍历为升序,因此只需要对输入序列按照升序排序,然后对完全二叉树进行中序遍历,填入相应的元素即可。最后层序遍历也不用队列实现,直接按编号循环输出就OK了


#include <cstdio>
#include <queue>
#include <algorithm>

#define MAX 1001

using namespace std;

int node[MAX];
int a[MAX];
int index = 0;

void dfs( int curRoot, int n ) {
    if( curRoot > n ) {
        return;
    }
    dfs( curRoot * 2, n );
    node[curRoot] = a[index++];
    //printf( "%d\n", node[curRoot] );
    dfs( curRoot * 2 + 1, n );
}

int main() {
    int n;
    scanf( "%d", &n );

    for( int i = 0; i < n; i++ ) {
        scanf( "%d", &a[i] );
    }

    sort( a, a + n );

    dfs( 1, n );

    for( int i = 1; i <= n; i++ ) {
        if( i == 1 )
            printf( "%d", node[i] );
        else
            printf( " %d", node[i] );
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值