PAT甲级1064. Complete Binary Search Tree (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  1. The left subtree of a node contains only nodes with keys less than the node’s key.

  2. The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.

  3. Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4

利用BST的中序遍历序列是有序的这一性质,
先给题目中给出的序列排序,
然后进行中序遍历,按顺序填数。
又因为是完全二叉树,所以结点i的左子是(2*i+1),右子是(2*i+2) ,所以很容易进行各种遍历。

#include <cstdio>
using namespace std;
#include <vector>
#include <algorithm>
#include <queue>

const int MAX=1000+10;
int num[MAX],value[MAX];
int N;

int cnt=0;
void FillNums(int root){
  if((2*root+1)<N) FillNums(2*root+1);
  value[root]=num[cnt];
  cnt++;
  if(2*root+2<N) FillNums(2*root+2);
}

void LevelOrder(int root){
  queue<int> Q;
  Q.push(root);
  int flag=0;
  while(!Q.empty()){
    int tmp=Q.front();
    Q.pop();
    if(!flag) {
      printf("%d",value[tmp]);
      flag=1;
    }
    else printf(" %d",value[tmp]);
    if((2*tmp+1)<N) Q.push(2*tmp+1);
    if((2*tmp+2)<N) Q.push(2*tmp+2);
  }
}

int main(){
  scanf("%d",&N);

  for(int i=0;i<N;i++) scanf("%d",&num[i]);
  sort(num,num+N);

  FillNums(0);
  LevelOrder(0);

  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值