PAT(A) - 1110. Complete Binary Tree (25)

22 篇文章 0 订阅


Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:
NO 1

思路分析:题意给出一棵树的结构,判断它是不是完全二叉树。因为是完全二叉树,所以直接用数组存储,这样就好判断了。


// Accepted: about 18min

#include <cstdio>
#include <string.h>
#include <queue>

#define MAX 20

using namespace std;

typedef struct {
    int key;
    int left;
    int right;
} Node;

Node node[MAX];
int isRoot[MAX];
int tree[MAX];

int stringToInt( char str[] ) {
    int num = 0;

    for( int i = 0; i < strlen( str ); i++ ) {
        num = num * 10 + str[i] - '0';
    }

    return num;
}

void bfs( int root ) {
    queue<int> q;
    q.push( root );

    int cnt = 0;
    while( !q.empty() ) {

        int curNode = q.front();
        q.pop();

        //printf( "%d\n", curNode );
        tree[cnt++] = curNode;
        if( curNode == -1 ) continue;
        q.push( node[curNode].left );
        q.push( node[curNode].right );
    }
}

int main() {
    //freopen( "123.txt", "r", stdin );
    int n;
    scanf( "%d", &n );

    char a[3];
    char b[3];
    int child;

    for( int i = 0; i < n; i++ ) {
        scanf( "%s %s", a, b );
        node[i].key = i;
        if( !strcmp( a, "-" ) ) {
            node[i].left = -1;
        }
        else {
            child = stringToInt( a );
            node[i].left = child;
            isRoot[child] = 1;
        }
        if( !strcmp( b, "-" ) ) {
            node[i].right = -1;
        }
        else {
            child = stringToInt( b );
            node[i].right = child;
            isRoot[child] = 1;
        }
    }

    int root = -1;
    for( int i = 0; i < n; i++ ) {
        if( isRoot[i] == 0 ) {
            root = i;
            break;
        }
    }

    bfs( root );

    bool flag = true;
    for( int i = 0; i < n; i++ ) {
        if( tree[i] == -1 ) {
            flag = false;
            break;
        }
    }

    if( flag ) {
        printf( "YES %d\n", tree[n - 1] );
    }
    else {
        printf( "NO %d\n", root );
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值