PAT(A) - 1057. Stack (30)

10 篇文章 0 订阅
5 篇文章 0 订阅


Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:

Push  key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.

Sample Input:
17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop
Sample Output:
Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

思路分析:直接暴力会超时,我以前参考别人的代码,利用树状数组做的。今天看了晴神的书,用的分块思想,好神奇呀~


#include <cstdio>
#include <stack>
#include <cmath>
#include <string.h>

#define MAX 100000 + 10

using namespace std;

int block[316];
int table[MAX];
int sqr = ( int )sqrt( MAX );
stack<int> s;

using namespace std;

void Push( int num ) {
    s.push( num );
    block[num / sqr]++;
    table[num]++;
}

void Pop() {
    if( s.empty() ) {
        printf( "Invalid\n" );
        return;
    }
    int top = s.top();
    s.pop();
    table[top]--;
    block[top / sqr]--;
    printf( "%d\n", top );
}

void PeekMedian() {
    if( s.empty() ) {
        printf( "Invalid\n" );
        return;
    }
    int k = s.size();
    if( k % 2 == 1 ) k = ( k + 1 ) / 2;
    else k = k / 2;

    int sum = 0;
    int id = 0;
    while( sum + block[id] < k ) {
        sum = sum + block[id];
        id++;
    }

    int num = id * sqr;
    while( sum + table[num] < k ) {
        sum += table[num];
        num++;
    }

    printf( "%d\n", num );
}

int main() {
    //freopen( "123.txt", "r", stdin );
    int n;
    scanf( "%d", &n );

    char op[20];
    int num;

    for( int i = 0; i < n; i++ ) {
        scanf( "%s", op );
        if( !strcmp( op, "Push" ) ) {
            scanf( "%d", &num );
            Push( num );
        }
        else if( !strcmp( op, "Pop" ) ) {
            Pop();
        }
        else if( !strcmp( op, "PeekMedian" ) ) {
            PeekMedian();
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值