PAT(A) - 1126. Eulerian Path (25)

1126. Eulerian Path (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian

题意很简单,给你一个无向图,判断它是否为欧拉图、半欧拉图、或不是欧拉图。

欧拉图就是包含欧拉回路,判断方法是图中所有节点度均为偶数。

半欧拉图是包含欧拉通路,但不是回路,判断方法是图中只有2个度为奇数的节点(就是欧拉通路的2个端点)。

不满足以上两点就不是欧拉图。

但有一个坑,这个图可能不连通,所以你要搜一遍。姥姥是厉害,,继链表题的又一个神坑。。

#include <cstdio>

#define MAX 500 + 10

int degree[MAX];
int MGraph[MAX][MAX];

int visit[MAX];

void dfs( int v, int n ) {
    visit[v] = 1;
    for( int i = 1; i <= n; i++ ) if( !visit[i] && MGraph[v][i] ) dfs( i, n );
}

int main() {
    int n, m;
    scanf( "%d%d", &n, &m );
    for( int i = 0; i < m; i++ ) {
        int a, b;
        scanf( "%d%d", &a, &b );
        degree[a]++;
        degree[b]++;
        MGraph[a][b] = MGraph[b][a] = 1;
    }

    int cnt1 = 0;   // 度为偶数节点
    int cnt2 = 0;   // 度为奇数节点
    for( int i = 1; i <= n; i++ ) {
        if( i == 1 ) printf( "%d", degree[i] );
        else printf( " %d", degree[i] );
        if( degree[i] % 2 == 0 ) cnt1++;
        else cnt2++;
    }

    // 搜一遍判断是否为连通图
    dfs( 1, n );
    int flag = true;
    for( int i = 1; i <= n; i++ ) { if( !visit[i] ) flag = false; }
    if( !flag ) { printf( "\nNon-Eulerian\n" ); return 0; }

    if( cnt1 == n ) printf( "\nEulerian\n" );
    else if( cnt1 == n - 2 && cnt2 == 2 ) printf( "\nSemi-Eulerian\n" );
    else printf( "\nNon-Eulerian\n" );

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值