1126 Eulerian Path(DFS)

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

题目大意

所有顶点均有偶数度的连通图必然含有欧拉回路,这样的图称为欧拉图。如果连通图中恰有两个顶点有奇数度,则所有的欧拉路径均不是欧拉回路,这样的图称作半欧拉图。给出一个无向图,判断它是欧拉图、半欧拉图还是非欧拉图。
注意这里欧拉图和半欧拉图的前提是连通图,所以必须加一个DFS/BFS判断该图是否连通,然后根据每个点的度数判断即可。

AC代码

#include <iostream>
#include <vector> 
using namespace std; 

const int maxn = 501;
int degree[maxn] = {0};
vector<int> G[maxn];
bool vis[maxn] = {false};

void DFS(int x){
	vis[x] = true;
	if(G[x].size() == 0) return;
	for(int i = 0; i < G[x].size(); i++)
		if(vis[G[x][i]] == false)
			DFS(G[x][i]);
}

int main(){
	int n, m, a, b;	
	cin>>n>>m;
	for(int i = 0; i < m; i++){
		cin>>a>>b;
		G[a].push_back(b);
		G[b].push_back(a);
		degree[a]++;
		degree[b]++;
	}
	int cnt = 0; //度为奇数的顶点数量 
	for(int i = 1; i <= n; i++){
		if(degree[i] % 2 == 1)
			cnt++;
		if(i != n) cout<<degree[i]<<" ";
		else cout<<degree[i]<<endl;
	}
	bool flag = true; //是否为连通图
	DFS(1);
	for(int i = 1; i <= n; i++)
		if(vis[i] == false){
			flag = false;
			break;
		} 
	if(flag && cnt == 0) cout<<"Eulerian";
	else if(flag && cnt == 2) cout<<"Semi-Eulerian";
	else cout<<"Non-Eulerian";
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值