poj1459 Power Network

这题是一个标准的最大流问题。

题目大意是:有n个点,其中nc个点是发电站,有np个点是用户,其他的是中转站,求最大流。

问题中存在着多源点和多汇点,我们可以把这些源点和汇点当作中转站,在虚拟一个超级源点和超级汇点,EK算法上模版

Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
13110572105      Log Out
Mail:2(1)
Login Log      Archive
Language:
Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 23154 Accepted: 12125

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u)  be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

Source

[Submit]   [Go Back]   [Status]    [Discuss]

Home Page   Go Back  To top


下面是代码

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <queue>
using namespace std;
const int inf = 1<<30;
const int M =105;
int map1[M][M],pre[M],vis[M],n;
int EK()
{
    int i,ans=0,now,min1;
    queue <int> q;
    while(1)  //每循环一次找一次增广路
    {
        memset(pre,-1,sizeof(pre));
        memset(vis,0,sizeof(vis));
        while(!q.empty())
        {
            q.pop();
        }
        q.push(0);
        vis[0]=1;
        while(!q.empty())
        {
            now=q.front();
            q.pop();
            if(now==n+1) //已经搜索到超级汇点  跳出循环
            {
                break;
            }
            for(i=0;i<=n+1;i++)
            {
                if(!vis[i]&&map1[now][i]>0)//如果节点i没被搜索过且节点now到节点i残余流量大于0
                {
                    pre[i]=now; //记录i的前驱节点是now
                    vis[i]=1;  //标记i点已经被访问过
                    q.push(i);  //把i点放入队列进行下一次BFS
                }
            }
        }
        if(!vis[n+1])
        {
            break;  //如果BFS完毕没有搜到到节点n+1的增广路,就已经找到最大流  跳出
        }
        min1=inf;
        for(i=n+1;i!=0;i=pre[i])
        {
            if(map1[pre[i]][i]<min1)  //寻找整个增广路上的残余流量的最小值,此为整个增广路的流量
            {
                min1=map1[pre[i]][i];
            }
        }
        ans+=min1;
        for(i=n+1;i!=0;i=pre[i])
        {
            map1[pre[i]][i]-=min1;//残余流量减少
            map1[i][pre[i]]+=min1;//已使用流量增加
        }
    }
    return ans;
}
int main()
{
    int np,nc,m,i;
    while(cin >> n >> np >> nc >> m)
    {
        char s;
        int u,v,w;
        memset(map1,0,sizeof(map1));
        for(i=0;i<m;i++)
        {
            cin >> s >> u >> s >> v >> s >> w;
            if(u!=v)
            {
                map1[u+1][v+1]=w;
            }
        }
        for(i=0;i<np;i++)
        {
            cin >> s >> v >> s >> w ;
            map1[0][v+1]=w;
        }
        for(i=0;i<nc;i++)
        {
            cin >> s >> u >> s>> w ;
            map1[u+1][n+1]=w;
        }
       cout << EK() << endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值