第十届acm省赛-F-Binary to Prime

问题 F: Binary to Prime
时间限制: 1 Sec 内存限制: 128 MB
题目描述
To facilitate the analysis of a DNA sequence, a DNA sequence is represented by a binary number. The group of DNA-1 has discovered a great new way . There is a certain correlation between binary number and prime number. Instead of using the ordinary decadic numbers, they use prime base numbers. Numbers in this base are expressed as sequences of zeros and ones similarly to the binary numbers, but the weights of bits in the representation are not powers of two, but the elements of the primes ( 2, 3, 5, 7,… ).

For example 01101 , ie. 2+5+7=14

Herefore, it is necessary to convert the binary number to the sum of prime numbers

输入
The input consists of several instances, each of them consisting of a single line. Each line of the input contains a 01 string, length of not more than 150. The end of input is not marked in any special way.

输出
For each test case generate a single line containing a single integer , The sum of the primes.

样例输入

000010
0011
11001

样例输出

3
5
20

提示
每个二进制位对应一个素数位权,
代码:

#include<bits/stdc++.h>
using namespace std;
int a[200];
void p()//初始化一个从小到大排序的素数数组;
{
    int i;
    double q;
    i=0;
    for(int t=2;i<200;t++)
    {
        int fa=1;
        for(int j=2;j<=sqrt(t);j++)
        {
            if(t%j==0)
            {
                fa=0;break;
            }
        }
        if(fa)
            a[i++]=t;
    }
}
int main()
{
    int sum;
    char s[200];
    p();
    while(~scanf("%s",s))
    {
        int l=strlen(s);
        sum=0;
        for(int i=0;i<l;i++)
        {
            if(s[l-i-1]=='1')//注意位权是从右往左增大的;
            {
                sum+=a[i];
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值