hdu-6098-Inversion

Inversion传送门

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 115    Accepted Submission(s): 81


Problem Description
Give an array A, the index starts from 1.
Now we want to know  Bi=maxijAj  ,  i2 .
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer n : the size of array A.
Next one line contains n integers, separated by space, ith number is  Ai .

Limits
T20
2n100000
1Ai1000000000
n700000
 

Output
For each test case output one line contains n-1 integers, separated by space, ith number is  Bi+1 .
 

Sample Input
  
  
2 4 1 2 3 4 4 1 4 2 3
 

Sample Output
  
  
3 4 3 2 4 4
 
题意:
输出bj~~bn  j不是i的因子的最大ai
思路:暴力即可
code:
#include <iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct book{
    int shu,xb;
}s[100010];
bool cmp(book x,book y)
{
    return x.shu>y.shu;
}
int h[100010];
int main()
{
   int T,n,i;
   scanf("%d",&T);
   while(T--)
   {
       scanf("%d",&n);
       for(i=1;i<=n;++i)
       {
           scanf("%d",&s[i].shu);
           s[i].xb=i;
       }
       sort(s+1,s+i,cmp);
       for(int j=2;j<=n;j++)
       {
          for(i=1;i<=n;i++)
          {
              if(s[i].xb%j!=0)
                {
                    h[j]=s[i].shu;
                    break;
                }
          }
       }
       for(int j=2;j<n;j++)
            printf("%d ",h[j]);
       printf("%d\n",h[n]);
   }
    return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值