HDU6098 Inversion -2017多校联盟6 第3题

Inversion

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 30    Accepted Submission(s): 18


Problem Description
Give an array A, the index starts from 1.
Now we want to know Bi=maxijAj , i2 .
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer n : the size of array A.
Next one line contains n integers, separated by space, ith number is Ai .

Limits
T20
2n100000
1Ai1000000000
n700000
 

Output
For each test case output one line contains n-1 integers, separated by space, ith number is Bi+1 .
 

Sample Input
  
  
2 4 1 2 3 4 4 1 4 2 3
 

Sample Output
  
  
3 4 3 2 4 4
 

Source



题意
给定ai , i∈[1,n]   定义bi , i∈[2,n+1]
Bi=maxijAj , i2
i不是j的因子

将ai排序,倒着找,第一个不是i的倍数的j对应的aj就是bi

代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
typedef long long LL;
const int maxn = 100000 + 10;
struct data{
    LL val;
    int pos;
}a[maxn];

int cmp1(const data a,const data b){
    return a.val < b.val;
}
LL b[maxn];
int main()
{
    int t;

    scanf("%d", &t);
    while (t > 0)
    {
        t--;
        int n;
        scanf("%d",&n);
        for(int i = 0;i<n;++i){
            scanf("%lld",&a[i].val);
            a[i].pos = i+1;
        }
        sort(a,a+n, cmp1);
        for(int i = 2;i<=n;++i){
            for(int j = n-1;j>=0;--j){
                if(a[j].pos%i) {b[i] = a[j].val;break;}
            }
        }
        for(int i = 2;i<=n;++i){
            if(i!=2) printf(" ");
            printf("%lld",b[i]);
        }
        puts("");

    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值