hdu-2492-Ping pong(树状数组)

Ping pong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5566    Accepted Submission(s): 2077


Problem Description
N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). 

Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.

The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?
 

Input
The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.


Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).
 

Output
For each test case, output a single line contains an integer, the total number of different games.
 

Sample Input
  
  
1 3 1 2 3
 

Sample Output
  
  
1

题意:给你n个人,每个人有自己的攻击力,输入的顺序就是每个人的顺序,他们之间互相比赛,两个人比赛的条件是必须在他们两个位置之间找到一个人当裁判,这个裁判的攻击力必须在他们两个人之间,问你最多能矩形多少场比赛。
思路:
枚举每个点当裁判,左边小于的和右边大于他的相乘 加上 左边大于他的乘上右边小于他的。用树状数组
先用0初始化c数组。再扫一遍,每一次都把sum[a[i]] 加一 并且更新受影响的值,并求出a[i]-1的前缀和,这个和就是在i前面比i的人数。
code  
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define lowbit(x) (x&(x^(x-1)))
#define maxn 100000+5
using namespace std;
int n,m;
int c[maxn],a[maxn],b[maxn],d[maxn];
void update(int p)
{
    while(p<=m){
        c[p]++;
        p+=lowbit(p);
    }
}
int sum(int p)
{
    int ans=0;
    while(p>0){
        ans+=c[p];
        p-=lowbit(p);
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        m=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            m=max(a[i],m);
        }
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++){
            update(a[i]);
            b[i]=sum(a[i]-1);///第 i 个人前面比他小的人数,存入b数组中
        }
        memset(c,0,sizeof(c));
        for(int i=n;i>0;i--){
            update(a[i]);
            d[i]=sum(a[i]-1);///第 i 个人后面比他小的人数,存入b数组中
        }
        long long ans=0;
        for(int i=2;i<n;i++)
            ans+=b[i]*(n-d[i]-i)+ d[i]*(i-b[i]-1);
        printf("%lld\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值