HDU 问题1084 What Is Your Grade?(结构体+sort)

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11928    Accepted Submission(s): 3817



Problem Description

“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
 

Input

Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 

Output

Output the scores of N students in N lines for each case, and there is a blank line after each case.
 

Sample Input

  
  
4 5 06:30:17 4 07:31:27 4 08:12:12 4 05:23:13 1 5 06:30:17 -1
 

Sample Output

  
  
100 90 90 95 100
 

Author
lcy

题目大意:
           做对5道题满分,四道题95或90(做对四道题人中前一半得分95,后一半90),以此类推...   0道50分,输出每个人相应的成绩.
                 
代码:

#include<iostream>  
#include<algorithm> 
#include<string> 
using namespace std;  
  
struct student
{  
	int num;
	string time; 
	int pos,base;//pos记录次序,base记录基础得分
}stu[102];  

int arr[6];//arr[i]表示做对i道题的人的人数 
  
bool cmp1(student a, student b)  
{  
    if(a.num == b.num) return a.time< b.time;  
    return a.num > b.num;  
}  
  
bool cmp2(student a, student b)  
{  
    return a.pos < b.pos;  
}  
  
int main()  
{  
    int n;  
    while(cin>>n && n > 0)
	{  
            for(int i = 1; i < 6; i++)  
                arr[i] = 0;  
	    for(int i = 0; i < n; i++)
	    {  
             
            cin>>stu[i].num>>stu[i].time;    
            stu[i].base = 100 - (5 - stu[i].num) * 10;
			stu[i].pos = i;  
            arr[stu[i].num]++;  
            }  
          
            sort(stu, stu + n, cmp1);  
          
            for(int i = 4, pos = 0; i>0; i--)
	    {  
                if(arr[i])
		{  
                    while(stu[pos].num != i) 
                          pos++;  
                
		    if(arr[i] == 1)//一个人时额外考虑
                            stu[pos++].base += 5;              
                
		    for(int j = 0; j < arr[i] / 2; j++)//做对相同题目的前一半人得分加5  
                        stu[pos++].base += 5;  
                }  
            }  
          
        sort(stu, stu + n, cmp2);  
          
        for(int i = 0; i < n; ++i)  
            cout<<stu[i].base<<endl;  
        cout<<endl;  
    }  
    return 0;  
}  




 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值