What Is Your Grade?

Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam! 
Come on!
 
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
 
Sample Output
100
90
90
95

100
 
Author
lcy
 

注:题目意思是说同一个分数的人,如果在该分数段排名名次超过1半以上,则选择打高分

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct student
{
    int point;
    int time;//保存时间
};

int cmp(const void *a,const void *b)
{
    struct student *c=(struct student *)a;//类型转换
    struct student *d=(struct student *)b;
    if(c->point==d->point)
    {
        return c->time - d->time;//如果完成题数一样,按照时间大小排序 由小到大
    }
    else return d->point - c->point;//由大到小 按完成题数排列
}

int main(void)
{
    int num=0;
    int i=0;
    struct student grade[101];
    struct student *p;//定义一个指向结构体的指针
    int h,m,s;
    int count[6];
    int temp=0;
    struct student *tmp;



 while(   scanf("%d",&num) )
 {
     if(num<0) break;

    memset(count,0,sizeof(count));//数组初始化为0
    memset(grade,0,num*sizeof (struct student));//

    for(i=0;i<num;i++)
    {
        scanf("%d %d:%d:%d",&grade[i].point,&h,&m,&s);
        grade[i].time=h*3600+m*60+s;
        count[grade[i].point]++;
    }


    tmp= (struct student*)malloc(num * sizeof (struct student));
    memcpy(tmp,grade,num * sizeof (struct student));//内存拷贝函数
    qsort(grade,num,sizeof(struct student),cmp);//全部按照从小到大排序

    for(p=tmp;p<(tmp+num);p++)
    {
        if(p->point==5)
        {
            printf("100\n");
        }
        else
        if(p->point==4)
        {
            if(count[4]==1)
                printf("95\n");
            else
            {
                temp=count[5]+count[4]/2;
                if(p->time < (grade+temp)->time)
                {
                    printf("95\n");
                }
                else printf("90\n");
            }
        }

        else
        if(p->point==3)
        {
            if(count[3]==1)
                printf("85\n");
            else
            {
                temp=count[5]+count[4]+count[3]/2;
                if(p->time < (grade+temp)->time)
                {
                    printf("85\n");
                }
                else printf("80\n");
            }
        }

        else
        if(p->point==2)
        {
            if(count[2]==1)
                printf("75\n");
            else
            {
                temp=count[5]+count[4]+count[3]+count[2]/2;
                if(p->time < (grade+temp)->time)
                {
                    printf("75\n");
                }
                else printf("70\n");
            }
        }

        else
        if(p->point==1)
        {
            if(count[1]==1)
                printf("65\n");
            else
            {
                temp=count[5]+count[4]+count[3]+count[2]+count[1]/2;
                if(p->time < (grade+temp)->time)
                {
                    printf("65\n");
                }
                else printf("60\n");
            }
        }

        else printf("50\n");
    }
    printf("\n");
    free(tmp);

 }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值