HDU 1084:What Is Your Grade?

5 篇文章 0 订阅

Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!

Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0 &lt; p . 0&lt;p. 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.

Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.

Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1

Sample Output
100
90
90
95

100


题意:输入n,表示n个人,第一个数表示做出了来的题数,第二个表示时间,做题数等于5得100分,4题时当做题时间排在前一半的时候得95,后一半得90,以此类推,题数等于0得0分。
/*放寒假以来第一次在没有空调的桌子旁写题,真的冷QAQ冷的没思路,看了大佬的题解才有了思路,代码也是模仿的
点击查看参(chao)考(xi)的代码QAQ */
我的代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct wzy{
	int point,I,NO;
	int h,m,s;
}p[200];
int cmp(wzy u,wzy v)
{
	if(u.point==v.point)
	{
		if(u.h==v.h){
			if(u.m==v.m){
				return u.s<v.s;
			}
			else return u.m<v.m;
		}
		else return u.h<v.h;
	}
	return u.point>v.point;
}
int cmp1(wzy u,wzy v)
{
	return u.I<v.I;
}
int main()
{
	int n,i;
	int k1,k2,k3,k4;
	int b1,b2,b3,b4;
	while(~scanf("%d",&n))
	{
		k1=k2=k3=k4=1;
		b4=b3=b2=b1=0;
		if(n<=0) break;
		for(i=0;i<n;i++)
		{
			scanf("%d %d:%d:%d",&p[i].point,&p[i].h,&p[i].m,&p[i].s);
			p[i].I=i;
			if(p[i].point==4) b4++;
			if(p[i].point==3) b3++;
			if(p[i].point==2) b2++;
			if(p[i].point==1) b1++;
		}
		sort(p,p+n,cmp);
		for(i=0;i<n;i++)//记录每个题数所在的位置 (排名) 
        {  
			if(p[i].point==4) p[i].NO=k4++;
			if(p[i].point==3) p[i].NO=k3++;
			if(p[i].point==2) p[i].NO=k2++;
			if(p[i].point==1) p[i].NO=k1++;
        }
        sort(p,p+n,cmp1);
        for(i=0;i<n;i++)  
        {  
        
            if(p[i].point==5) printf("100\n");
            if(p[i].point==4)
            {  
                if(p[i].NO<=b4/2) printf("95\n");
                else printf("90\n");
            }  
            if(p[i].point==3)  
            {  
                if(p[i].NO<=b3/2) printf("85\n");
                else printf("80\n");
            }  
            if(p[i].point==2)  
            {  
                if(p[i].NO<=b2/2) printf("75\n");
                else printf("70\n");
            }  
			if(p[i].point==1)  
            {  
                if(p[i].NO<=b1/2) printf("65\n");
                else printf("60\n");
            }  
            if(p[i].point==0) printf("50\n");
        }
        printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值