hdu 1711 Number Sequence

Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36723 Accepted Submission(s): 15205

Problem Description
Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output
6
-1

Source
HDU 2007-Spring Programming Contest

Recommend
lcy | We have carefully selected several similar problems for you: 1358 3336 3746 2222 2087

题目大意:
给定T组数据,每组有n,m个数字,寻求第二串数字在第一串数字中第一次出现的位置

做法:
KMP模板练习

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <string>
#include <algorithm>
#define N 10007
using namespace std;
int p[N], a[N * 100], b[N];
int T, n, m;

void work()
{
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; i++)
        scanf("%d", &a[i]);
    for (int i = 1; i <= m; i++)
        scanf("%d", &b[i]);
    memset(p, 0, sizeof(p));
    int j = 0;
    for (int i = 2; i <= m; i++)
    {
        while (b[j + 1] != b[i] && j > 0)   j = p[j];
        if (b[j + 1] == b[i])   j++;
        p[i] = j;
    }
    j = 0;
    bool w = false;
    for (int i = 1; i <= n; i++)
    {
        while (b[j + 1] != a[i] && j > 0)   j = p[j];
        if (b[j + 1] == a[i])   j++;
        if (j == m)
        {
            w = true;
            printf("%d\n", i - m + 1);
            break;
        }
    }
    if (!w) printf("-1\n");
}

int main()
{
    scanf("%d", &T);
    while (T--) work();
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值