HDU 1711 Number Sequence

2 篇文章 0 订阅
1 篇文章 0 订阅

Problem Description
Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output
6
-1

题意:给定两个数组,输出第一个数组中与第二个数组完全匹配的首个元素的位置,若不能匹配,输出-1

思路:
N最大为1000000,用KMP算法

#include <iostream>
using namespace std;
int N,M;
int a[1000010],b[10005],Next[10005];
void getNext()//得到数组b中每个元素的next值
{
    Next[0]=-1;
    int k=-1,j=0;
    while(j<M)
    {
        if(k==-1||b[k]==b[j])
        {
            k++;
            j++;
            Next[j]=k;
        }
        else
            k=Next[k];//递归找长度更短的相同前缀后缀
    }
}
int KMP()
{
    int i=0,j=0;
    while(i<N&&j<M)
    {
        if(j==-1||a[i]==b[j])//若匹配,移动到下一位
        {
            j++;
            i++;
        }
        else
            j=Next[j];//不匹配,i不变,下标j移动到数组b中上一个值为b[j]的位置
    }
    if(j==M)
        return i-j+1;
    else
        return -1;
}
int main()
{
    int T,ans;
    cin>>T;
    while(T--)
    {
        cin>>N>>M;
        if(M<=N)
        {
            for(int i=0;i<N;i++)
                cin>>a[i];
            for(int i=0;i<M;i++)
                cin>>b[i];
            getNext();
            ans=KMP();
            cout<<ans<<endl;
        }
        else//若M>N,不能匹配
            cout<<"-1"<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值