poj 2828Buy Tickets(线段树)

题目描述:
Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 17439 Accepted: 8653
Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output

77 33 69 51
31492 20523 3890 19243
Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

2828

题意:人们一个一个的来排队,后来的人可以插队,按人到来的顺序给出每个人插队的位置(插在第几个人后面),并告知每个人的属性vi,输出最终队伍的情况。

分析:
线段树,由题意知后面来的人一定可以在自己想要的位置,可以逆向将每个人排列,用线段树来储存在该结点区域内还剩多少个空位置,每次加入一个人时查找合适的位置并更新结点信息即可。

ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=200005;
struct node                     //线段树结点,储存左右边界和在该区间的空位置 
{
    int l,r,n;
}a[maxn*8];

struct fun
{
    int p,v,m;                    //p是每个人插队时想要的位置,m是最终结果的位置,v是每个人的属性 
}c[maxn];

void build(int o,int l,int r)     // 构造线段树 
{
    a[o].l=l;
    a[o].r=r;
    a[o].n=r-l+1;
    if(l==r)
    return;
    else
    {
        int mid=l+(r-l)/2;
        build(o*2,l,mid);
        build(o*2+1,mid+1,r);
    }
    return;
}

int query(int o,int l,int r,int v)      //查询在结点o(左右边界为l,r),v是希望插入的位置 返回值为最终插入的位置 
{
    int m;
    int mid=l+(r-l)/2;
    int have=a[o*2].n;
    if(l==r)
    return l;
    if(v>have)
    m=query(o*2+1,mid+1,r,v-have);
    else
    m=query(o*2,l,mid,v);
    return m;
}
void insert(int o,int l,int r,int p)      //跟新结点信息,将所以包含第p个位置的所以结点更新 
{
    a[o].n--;
    if(l==r)
    return;
    int mid=l+(r-l)/2;
    if(mid<p)
    insert(o*2+1,mid+1,r,p);
    else
    insert(o*2,l,mid,p);    
}

bool cmp(fun a,fun b)
{
    return a.m<b.m;
}

int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        build(1,1,n);
        for(int i=0;i<n;i++)
        scanf("%d%d",&c[i].p,&c[i].v);
        for(int i=n-1;i>=0;i--)                             //逆序插入 
        {
            int q=query(1,1,n,c[i].p+1);
            c[i].m=q;
            insert(1,1,n,q);
        }
        sort(c,c+n,cmp);                                    //按最终位置排序 
        for(int i=0;i<n;i++)
        printf("%d ",c[i].v);
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值