poj 1511 Invitation Cards(最短路)

Invitation Cards
Time Limit: 8000MS Memory Limit: 262144K
Total Submissions: 25583 Accepted: 8472

Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

Source


题意:

给出n个顶点m条边的有向图,算出从第1点到其他各个顶点的最短路径的和,再算出从其他各个顶点到第一个顶点的最短路径的和,求出两个和的和.


题解:

这一题用Dijkstra和floyed都会超时。。。
对于点多边少的,用SPFA效率较高。

求其他点到1点的最短路径是需要转换思维,其实就相当于将原图所有边换方向,然后再以点1为起点求最短路径.

所以这一题用两次SPFA,分别对原图和逆图(所有边与原图相反)求最短路径


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn=1e6+10;
const ll inf=0x3f3f3f3f3f3f;
ll d[maxn],d1[maxn];
int q[maxn],inq[maxn],head[maxn],head1[maxn];
int tol,tol1;

struct Edge
{
	int to,next;
	ll w;
}edge[maxn],edge1[maxn];

void init()
{
	tol=0;
	tol1=0;
	memset(head1,-1,sizeof(head1));
	memset(head,-1,sizeof(head));
	for(int i=1;i<maxn;i++) d[i]=inf;
	for(int i=1;i<maxn;i++) d1[i]=inf; 
}

void addedge(int u,int v,ll w)
{
	edge[tol].to=v,edge[tol].w=w,edge[tol].next=head[u],head[u]=tol++;
	edge1[tol1].to=u,edge1[tol1].w=w,edge1[tol1].next=head1[v],head1[v]=tol1++;
}

void spfa()
{
	memset(inq,0,sizeof(inq));
	memset(q,0,sizeof(q));
	int front=0,rear=0;
	q[rear++]=1;
	inq[1]=1;
	d[1]=0;
	while(front!=rear)
	{
		int u=q[front++];
		inq[u]=0;
		if(front>=maxn) front=0;
		for(int i=head[u];i!=-1;i=edge[i].next)
		{
			int v=edge[i].to;
			if(d[v]>d[u]+edge[i].w)
			{
				d[v]=d[u]+edge[i].w;
				if(inq[v]) continue;
				inq[v]=1;
				q[rear++]=v;
				if(rear>=maxn) rear=0;
			}
		}
	}
}

void spfa1()
{
	memset(inq,0,sizeof(inq));
	memset(q,0,sizeof(q));
	int front=0,rear=0;
	q[rear++]=1;
	inq[1]=1;
	d1[1]=0;
	while(front!=rear)
	{
		int u=q[front++];
		inq[u]=0;
		if(front>=maxn) front=0;
		for(int i=head1[u];i!=-1;i=edge1[i].next)
		{
			int v=edge1[i].to;
			if(d1[v]>d1[u]+edge1[i].w)
			{
				d1[v]=d1[u]+edge1[i].w;
				if(inq[v]) continue;
				inq[v]=1;
				q[rear++]=v;
				if(rear>=maxn) rear=0;
			}
		}
	}
}

int main()
{
	int cas;
	scanf("%d",&cas);
	while(cas--)
	{
		init();
		int n,m;
		scanf("%d%d",&n,&m);
		while(m--)
		{
			int u,v;
			ll w;
			scanf("%d%d%I64d",&u,&v,&w);
			addedge(u,v,w);
		}
		spfa();
		spfa1();
		ll ans=0;
		for(int i=2;i<=n;i++) ans+=d[i]+d1[i];
		printf("%I64d\n",ans);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值