poj 2923 Relocation(状压dp,好题)

Relocation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3209 Accepted: 1305

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

Source

TUD Programming Contest 2006, Darmstadt, Germany



题意: 有 n 个货物,并且知道了每个货物的重量,每次用载重量分别为c1,c2的火车装载,问最少需要运送多少次可以将货物运完。


题解:

解法为状态压缩DP+背包,本题的解题思路是先枚举选择若干个时的状态,总状态量为1<<n,判断这些状态集合里的那些物品能否一次就运走,如果能运走,那就把这个状态看成一个物品。预处理完能从枚举中找到tol个物品,再用这tol个物品中没有交集(也就是两个状态不能同时含有一个物品)的物品进行01背包,每个物品的体积是state[i],价值是1,求包含n个物品的最少价值也就是dp[(1<<n)-1](dp[i]表示状态i需要运的最少次数)。


状态转移方程:dp[j|k] = min(dp[j|k],dp[k]+1) (k为state[i,1<=j<=(1<<n)-1])。
算法复杂度O((2^N)*N)



#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAXN=(1<<10)+10;
const int INF=0x3f3f3f3f;
int a[15],d[MAXN],vis[110];
int state[1100];
int n,C1,C2;

bool check(int x)
{
	memset(vis,0,sizeof(vis));
	vis[0]=1;
	int sum=0;
	for(int i=0;i<n;i++)
	if(x&(1<<i))
	{
		sum+=a[i];
		for(int j=C1;j>=a[i];j--)
		if(vis[j-a[i]])                            //vis[j]=vis[j-a[i]];
		vis[j]=1;
	}
	if(sum>C1+C2) return false;
	for(int j=C1;j>=0;j--)
	 if(vis[j]&&C2>=sum-j)
	 return true;
	return false;
}

int main()
{
	int cas;
	scanf("%d",&cas);
	for(int k=1;k<=cas;k++)
	{
		int tol=0;
		scanf("%d%d%d",&n,&C1,&C2);
		for(int i=0;i<n;i++) scanf("%d",&a[i]);
		int tot=(1<<n)-1;
		for(int i=0;i<=tot;i++)
		{
			if(check(i)) state[tol++]=i;
			d[i]=INF;
		}
		d[0]=0;
		for(int i=0;i<tol;i++)
		{
			for(int j=tot;j>=0;j--)
			{
				if((j&state[i])==0)
				{
					d[j|state[i]]=min(d[j|state[i]],d[j]+1);
				}
			}
		}
		printf("Scenario #%d:\n%d\n\n",k,d[tot]);
	}
}



















  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值