ACM: 动态规划题 poj 2923

Relocation
Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers n, C1 and C2. C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

 

题意: Emma and Eric 蜜月回来, 他们有2部车载重量分别为c1,c2.

      有n件家俱, 每件家俱种类为w[i], 现在要用最少的次数运完全部的家俱.

 

解题思路: (这题没有思路, 从网上学会的)

     1. 物品种数是n个, 选取的状态有2^n种选择方式, (1<=n<=10)范围不大.

        先将可以用2车运送的选择方式求出来, 这是一次背包.

        分析:

        (1). 状态用二进制表示, 压缩状态嘛, 每次枚举一个状态, 0表示不选取,

             1表示选取. 显然, 背包关键值是c1或则c2, 每次的区间是[c1, w[i]]

             或则[c2, w[i]];

        (2). 最后是判断这次状态枚举是否可行.

     2. 在第一次背包保存下来的可行状态中, 接下来就是计算最少运算次数.

        设状态dp[i]表示i是二进制, 0表示未运, 1表示已经运, 在i状态下最少的运送次数.

        当前状态j不与状态situation[i]没有重复(因为每件物品只运送一次)时:

        dp[ j|situation[i] ] = min(dp[ j|situation[i] ], dp[j]+1);

        (j|situation[i]表示两个状态的合并)

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 11
const int INF = (1<<29);

int n, c1, c2;
int w[MAX], s;
int dp[1<<MAX], num, flag[1<<MAX];

inline int min(int a, int b)
{
 return a < b ?  a : b;
}

bool judge(int x)
{
 bool temp[1<<MAX];
 int i, j, sum = 0;
 memset(temp, false, sizeof(temp));
 temp[0] = 1;
 for(i = 0; i < n; ++i)
 {
  if( x & (1<<i) )
  {
   sum += w[i];
   for(j = c1; j >= w[i]; --j)
   {
    if( temp[ j-w[i] ] )
     temp[j] = true;
   }
  }
 }

 for(i = 0; i <= c1; ++i)
 {
  if( temp[i] && sum-i <= c2 )
   return true;
 }
 return false;
}

int DP()
{
 dp[0] = 0;
 for(int i = 0; i < num; ++i)
 {
  for(int j = s-1-flag[i]; j >= 0; --j)
  {
   if( !(j&flag[i]) ) //每个物品只运送一次.
   {
    dp[ j|flag[i] ] = min( dp[ j|flag[i] ], dp[j]+1 );
   }
  }
 }
 return dp[s-1];
}

int main()
{
// freopen("input.txt", "r", stdin);
 int i, caseNum, Num = 1;
 scanf("%d", &caseNum);
 while(caseNum--)
 {
  num = 0;
  scanf("%d %d %d", &n, &c1, &c2);
  for(i = 0; i < n; ++i)
   scanf("%d", &w[i]);
  
  s = 1<<n;
  for(i = 0; i < s; ++i)
  {
   if( judge(i) )
    flag[ num++ ] = i;
   dp[i] = INF;
  }

  printf("Scenario #%d:\n%d\n\n", Num++, DP());
 }

 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值