poj 2923(状态压缩+背包)

比较巧妙的一道题目,拿到题目就想用暴力直接搜索,仔细分析了下发现复杂度达到了2^n*n! ,明显不行,于是只好往背包上想。 于是又想二分找次数判断可行的方法,但是发现复杂度10^8还是很悬。。。
然后学习了这种背包状压的好思路, 巧妙的转化成了背包的模型。 一道经典的题目!
 
Relocation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1664 Accepted: 678

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

Source

TUD Programming Contest 2006, Darmstadt, Germany
 
 
 
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <string>
using namespace std;
#define INF 0x3ffffff

int c1,c2,n;
int g[11];
int save[10010];
int dp[10010];

int check(int s)
{
    int tg[10];
    int cnt=0;
    int sum=0;
    for(int i=0;i<n;i++)
    {
        if( ((1<<i)&s) != 0 )
        {
            tg[cnt++]=g[i];
            sum+=g[i];
        }
    }
    for(int i=0;i<(1<<cnt);i++)
    {
        int tmp,tmp1;
        tmp=tmp1=0;
        for(int j=0;j<cnt;j++)
        {
            if( ((1<<j)&i)!=0)
            {
                tmp+=tg[j];
            }
        }
        tmp1=sum-tmp;
        if(tmp<=c1&&tmp1<=c2)
        {
            return 1;
        }
    }
    // tmp tmp1 分别代表放入的不同地方
    return 0;
}

int main()
{
    int T;
    scanf("%d",&T);
    int tt=1;
    while(T--)
    {
        scanf("%d%d%d",&n,&c1,&c2);
        for(int i=0;i<n;i++)
            scanf("%d",g+i);
        int cnt=0;
        for(int i=1;i<(1<<n);i++)//不能从0开始吧
        {
            if(check(i)==1)
            {
                save[cnt++]=i;
            }
        }
        // 求出所有可以当成一次背包的所有情况
        // 从000000 -> 111111
        for(int i=1;i<(1<<n);i++)
            dp[i]=INF;
        dp[0]=0;
        for(int i=0;i<cnt;i++)
        {
            for(int j=(1<<n);j>=save[i];j--)
            {
                if( (j| save[i] ) != j) continue;
                dp[j]=min(dp[j],dp[j^save[i]]+1);
            }
        }

        printf("Scenario #%d:\n",tt++);
        printf("%d\n",dp[(1<<n)-1]);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值