POJ-1258 最小生成树 prim算法

prim(假设图是连通的,转化成连通网的最小生成树)
n个顶点----全部连通----n-1条路
mapp记录所有边
dis 记录权值
vis 标记是否经过
搜索最小边
把最小边加进去
累加到ans里
最后记得更新权值


Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39435 Accepted: 15987

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
 
最小生成树的模板题,不是很难,但是小循环的循环变量跟大循环用成一个了。。
改了好久才发现这里错了。。而且,坐标的下标标错了。好桑心。。
 
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define INF 0x3f3f3f3f

using namespace std;

int mapp[505][505];
int dis[5050];
int vis[5050];
int ans,flag;
int prim(int m)
{
    int i,j;
    int pos;
    int minn;
    memset(vis,0,sizeof(vis));
    // memset(dis,0,sizeof(dis));
    ans = 0;
    for(i=1; i<=m; i++)
    {
        dis[i] = mapp[1][i];
    }
    vis[1] = 1;
    for(i=1; i<=m-1; i++)
    {
        minn = INF;
        for(j=1; j<=m; j++)
        {
            if(vis[j]==0&&minn>dis[j])
            {
                pos = j;
                minn = dis[j];
            }
        }
        vis[pos] = 1;
        ans = ans + minn;
        if(minn>=INF)
        {
            break;
        }
        for(j=1; j<=m; j++)
        {
            if(vis[j]==0&&dis[j]>mapp[pos][j])
            {
                dis[j] = mapp[pos][j];
            }
        }
    }
    return ans;
}


int main()
{
    int n;
    int a;
    int t;
    while(scanf("%d",&n)!=EOF)
    {
        int i,j;
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                scanf("%d",&a);
                mapp[i][j] = a;
                mapp[j][i] = a;
            }
        }
        t = prim(n);
        printf("%d\n",t);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值