HDU 2757 优先队列+广搜

Ocean Currents


Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 904    Accepted Submission(s): 300




Problem Description
For a boat on a large body of water, strong currents can be dangerous, but with careful planning, they can be harnessed to help the boat reach its destination. Your job is to help in that planning.


At each location, the current flows in some direction. The captain can choose to either go with the flow of the current, using no energy, or to move one square in any other direction, at the cost of one energy unit. The boat always moves in one of the following eight directions: north, south, east, west, northeast, northwest, southeast, southwest. The boat cannot leave the boundary of the lake. You are to help him devise a strategy to reach the destination with the minimum energy consumption.
 


Input
The lake is represented as a rectangular grid. The first line of each test chunk contains two integers r and c, the number of rows and columns in the grid. The grid has no more than 1000 rows and no more than 1000 columns. Each of the following r lines contains exactly c characters, each a digit from 0 to 7 inclusive. The character 0 means the current flows north (i.e. up in the grid, in the direction of decreasing row number), 1 means it flows northeast, 2 means east (i.e. in the direction of increasing column number), 3 means southeast, and so on in a clockwise manner:


7 0 1
\|/
6-*-2
/|\
5 4 3


The line after the grid contains a single integer n, the number of trips to be made, which is at most 50. Each of the following n lines describes a trip using four integers rs, cs, rd, cd, giving the row and column of the starting point and the destination of the trip. Rows and columns are numbered starting with 1. 


Please process to the end of the data file.
 


Output
For each trip, output a line containing a single integer, the minimum number of energy units needed to get from the starting point to the destination.
 


Sample Input
5 5
04125
03355
64734
72377
02062
3
4 2 4 2
4 5 1 4
5 3 3 4
5 5
04125
03355
64734
72377
02062
3
4 2 4 2
4 5 1 4
5 3 3 4
 


Sample Output
0
2
1
0
2
1
 


Source
University of Waterloo Local Contest 2009.02.08
 


Recommend
lcy


代码:
#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;


int dir[8][2]={{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1}};


int m,n;
char map[1005][1005];
int res[1005][1005];
int p;
int sr,sc,er,ec;


struct pnt
{
    int r;
    int c;
    int res;
    int num;
    pnt(int x,int y,int z,int ct):r(x),c(y),res(z),num(ct){}
    pnt(){}
    friend bool operator < (pnt p1,pnt p2)
    {
        if(p1.res!=p2.res)
        {
            return p1.res>p2.res;
        }
        else
        {
            return p1.num>p2.num;
        }
    }
};


int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        for(int i=0;i<m;i++)
        {
            scanf("%s",map[i]);
        }
        scanf("%d",&p);
        for(int i=0;i<p;i++)
        {
            int cnt=1;
            memset(res,0x3f,sizeof(res));
            scanf("%d%d%d%d",&sr,&sc,&er,&ec);
            res[sr-1][sc-1]=0;
            priority_queue<pnt>q;
            q.push(pnt(sr-1,sc-1,0,1));
            while(!q.empty())
            {
                pnt pt=q.top();
                if(pt.r==er-1&&pt.c==ec-1)break;
                q.pop();
                int i;
                for(i=0;i<8;i++)
                {
                    int row=pt.r+dir[i][0];
                    int col=pt.c+dir[i][1];
                    if(row<0||col<0||row>=m||col>=n)continue;
                    if(i==map[pt.r][pt.c]-'0')
                    {
                        if(res[row][col]>res[pt.r][pt.c])
                        {
                            res[row][col]=res[pt.r][pt.c];
                            cnt++;
                            q.push(pnt(row,col,pt.res,cnt));
                        }
                    }
                    else
                    {
                        if(res[row][col]>pt.res+1)
                        {
                            res[row][col]=pt.res+1;
                            cnt++;
                            q.push(pnt(row,col,pt.res+1,cnt));
                        }
                    }
                }
            }
            printf("%d\n",res[er-1][ec-1]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值