PAT 1021. Deepest Root (25)

1021. Deepest Root (25)

时间限制
1500 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components

这道题首先要用Union-find来确定有几个连通图,如果有两个及两个以上直接输出Error。然后再求出树的直径,求树的直径即用两次BFS。第一次以任一点为起点进行BFS搜索,搜索出距离该点最远的所有点,这些点即是树的直径的其中一个端点。再以其中一个端点为起点进行第二次BFS,求出的点加上第一次BFS求出的点,就是所有直径的端点了。

代码如下:

#include <iostream>
#include <cstring>
#include <vector>
#include <queue>
#include <set>
using namespace std;
int root[10001];
vector<vector<int> > edge;
int dist[10001];
int visited[10001];
int findRoot(int x)
{
	if(root[x]!=x)
	{
		int rt=findRoot(root[x]);
		root[x]=rt;
	}
	return root[x];
}
void Union(int x,int y)
{
	int rootX=findRoot(x);
	int rootY=findRoot(y);
	root[rootX]=rootY;
}
int bfs(int v)
{
	dist[v]=1;
	int maxDist=1;
	queue<int> bfsqueue;
	bfsqueue.push(v);
	visited[v]=1;
	while(!bfsqueue.empty())
	{
		int x=bfsqueue.front();
		bfsqueue.pop();
		for(int i=0;i<edge[x].size();i++)
		{
			int y=edge[x][i];
			if(visited[y]==0)
			{
				visited[y]=1;
				bfsqueue.push(y);
				dist[y]=dist[x]+1;
				if(dist[y]>maxDist)
					maxDist=dist[y];
			}
		}
	}
	return maxDist;
}
int main(int argc, char** argv) {
	int N,i,x,y;
	cin>>N;
	for(i=0;i<10001;i++)
	{
		root[i]=i;
		dist[i]=0;
		visited[i]=0;
	}
	edge.clear();
	edge.resize(N+1);
	for(i=1;i<N;i++)
	{
		cin>>x>>y;
		edge[x].push_back(y);
		edge[y].push_back(x);
		Union(x,y);
	}
	set<int> rootNumber;
	for(i=1;i<=N;i++)
		rootNumber.insert(findRoot(i));
	if(rootNumber.size()!=1)
	{
		cout<<"Error: "<<rootNumber.size()<<" components"<<endl;
		return 0;
	}
	int step=bfs(*rootNumber.begin());
	set<int> result;
	for(i=1;i<=N;i++)
		if(dist[i]==step)
			result.insert(i);
	for(i=0;i<10001;i++)
	{
		dist[i]=0;
		visited[i]=0;
	}
	step=bfs(*result.begin());
	for(i=1;i<=N;i++)
		if(dist[i]==step)
			result.insert(i);
	set<int>::iterator it;
	for(it=result.begin();it!=result.end();it++)
		cout<<*it<<endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值