PAT 1058. A+B in Hogwarts (20)

1058. A+B in Hogwarts (20)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

这道题比较简单,代码如下:

#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <set>
using namespace std;
int main()
{
	int a[3],b[3];
	cin>>a[2];
	getchar();
	cin>>a[1];
	getchar();
	cin>>a[0]>>b[2];
	getchar();
	cin>>b[1];
	getchar();
	cin>>b[0];
	int result[3],carry=0;
	result[0]=a[0]+b[0];
	if(result[0]>=29)
	{
		result[0]-=29;
		carry=1;
	}
	result[1]=carry+a[1]+b[1];
	if(result[1]>=17)
	{
		carry=1;
		result[1]-=17;
	}
	else
		carry=0;
	result[2]=carry+a[2]+b[2];
	cout<<result[2]<<"."<<result[1]<<"."<<result[0];
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值