PAT 1066. Root of AVL Tree (25)

1066. Root of AVL Tree (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

    

    

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print ythe root of the resulting AVL tree in one line.

Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88

这道题就是考察AVL tree的insert操作,代码如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <cstring>
using namespace std;
typedef struct nodes{
	int element;
	int height;
	nodes* leftchild;
	nodes* rightchild;
	nodes(){
		leftchild=NULL;
		rightchild=NULL;
		height=0;
	}
}nodes;

int getheight(nodes* x)
{
	if(x==NULL)
		return -1;
	else
		return x->height;
}
nodes* LLrotation(nodes* x)
{
	nodes* left=x->leftchild;
	x->leftchild=left->rightchild;
	left->rightchild=x;
	x->height=max(getheight(x->leftchild),getheight(x->rightchild))+1;
	left->height=max(getheight(left->leftchild),getheight(left->rightchild))+1;
	return left;
}
nodes* RRrotation(nodes* x)
{
	nodes* right=x->rightchild;
	x->rightchild=right->leftchild;
	right->leftchild=x;
	x->height=max(getheight(x->leftchild),getheight(x->rightchild))+1;
	right->height=max(getheight(right->leftchild),getheight(right->rightchild))+1;
	return right;
}
nodes* LRrotation(nodes* x)
{
	nodes* left=x->leftchild;
	x->leftchild=RRrotation(left);
	return LLrotation(x);
}
nodes* RLrotation(nodes* x)
{
	nodes* right=x->rightchild;
	x->rightchild=LLrotation(right);
	return RRrotation(x);
}


nodes* insertNode(nodes* target,int node)
{
	if(target==NULL)
	{
		target=new nodes;
		target->element=node;
	}	
	else if(node<target->element)
	{
		target->leftchild=insertNode(target->leftchild,node);
		int left=getheight(target->leftchild);
		int right=getheight(target->rightchild);
		if(left-right>1)
		{
			if(node<target->leftchild->element)
				target=LLrotation(target);
			else
				target=LRrotation(target);	
		}
		else
			target->height=max(left,right)+1;
	}
	else
	{
		target->rightchild=insertNode(target->rightchild,node);
		int left=getheight(target->leftchild);
		int right=getheight(target->rightchild);
		if(left-right<-1)
		{
			if(node<target->rightchild->element)
				target=RLrotation(target);
			else
				target=RRrotation(target);
		}
		else
			target->height=max(left,right)+1;
	}
	return target;
}
int main(void)
{
	int N;
	cin>>N;
	nodes* root=NULL;
	while(N--)
	{
		int node;
		cin>>node;
		root=insertNode(root,node);
	}
	cout<<root->element;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值