PAT 1067. Sort with Swap(0,*) (25)

1067. Sort with Swap(0,*) (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10 3 5 7 2 6 4 9 0 8 1
Sample Output:
9

这道题的要求就是只能把0与其他数字交换,最后得到一个递增数列。如果一遍遍for循环的话会运行超时,所以要稍微优化一下。

我的方法是另外开了一个position数组,position[8]=2就代表数字8目前正在第2位上。因此通过这个数组能很快的找到各个数的位置(其实我觉得用map应该也可以过)。

代码如下: 

#include <iostream>
#include <algorithm>
#include <cmath>
#include <map>
#include <cstring>
using namespace std;

int main(void)
{
	int N,i,right=0;
	scanf("%d",&N);
	int ori[100000];
	int position[100000];
	for(i=0;i<N;i++)
	{
		scanf("%d",&ori[i]);
		if(ori[i]==i)
			right++;
		position[ori[i]]=i;
	}
	int done=1,count=0;
	while(true)
	{
		if(right==N)
			break;
		if(ori[0]==0)
		{
			for(i=done;i<N;i++)
				if(ori[i]!=i)
				{
					ori[0]=ori[i];
					position[ori[i]]=0;
					ori[i]=0;
					position[0]=i;
					count++;
					right--;
					done=i;
					break;
				}
		}
		int pos0=position[0];
		int pos=position[pos0];
		ori[pos]=0;
		ori[pos0]=pos0;
		position[0]=pos;
		position[pos0]=pos0;
		if(pos==0)
			right++;
		count++;
		right++;
	}
	printf("%d",count);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值