1076. Forwards on Weibo (30)
Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:
M[i] user_list[i]
where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.
Then finally a positive K is given, followed by K UserID's for query.
Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.
Sample Input:7 3 3 2 3 4 0 2 5 6 2 3 1 2 3 4 1 4 1 5 2 2 6Sample Output:
4 5
这道题就相当于给一个有向图,找出给定path长度内的最大节点数。用BFS可以解决,代码如下:
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <iomanip>
#include <cstring>
using namespace std;
int visited[1001];
int relation[1001][1001];
int N,L;
int bfs(int x)
{
queue<int> myQueue;
myQueue.push(x);
visited[x]=1;
int level=0,count[6],total=0;
memset(count,0,sizeof(count));
count[0]=1;
while(level<L&&myQueue.size())
{
int front=myQueue.front();
myQueue.pop();
count[level]--;
for(int i=1;i<=N;i++)
{
if(!visited[i]&&relation[front][i]>0)
{
myQueue.push(i);
count[level+1]++;
total++;
visited[i]=1;
}
}
if(count[level]==0)
level++;
}
return total;
}
int main(void)
{
int i;
cin>>N>>L;
memset(relation,0,sizeof(relation));
for(i=1;i<=N;i++)
{
int M;
cin>>M;
while(M--)
{
int f;
cin>>f;
relation[f][i]=1;
}
}
int K;
cin>>K;
while(K--)
{
int query;
cin>>query;
memset(visited,0,sizeof(visited));
cout<<bfs(query)<<endl;
}
}