PAT 1082. Read Number in Chinese (25)

1082. Read Number in Chinese (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero ("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:
yi Shi Wan ling ba Bai

这道题大概是考逻辑?总之仔细点就好了,代码如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <string>
#include <vector>
#include <cstring>
using namespace std;
int main(void)
{
	string raw;
	cin>>raw;
	string trans[10]={"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
	string x[9]={"","Shi","Bai","Qian","Wan","Shi","Bai","Qian","Yi"};
	if(raw[0]=='-')
	{
		cout<<"Fu ";
		raw=raw.substr(1);
	}
	reverse(raw.begin(),raw.end());
	int size=raw.size();
	bool flag=false;
	for(int i=size-1;i>0;i--)
	{
		if(i==size-1)
		{
			cout<<trans[raw[i]-'0'];
			cout<<" "<<x[i];
		}
		else
		{
			if(raw[i]!='0')
			{
				if(flag==true)
				{
					flag=false;
					cout<<" "<<trans[0];
				}
				cout<<" "<<trans[raw[i]-'0'];
				cout<<" "<<x[i];
			}
			else
			{
				flag=true;
				if(i==4)
					cout<<" "<<x[4];
			}
		}
	}
	if(flag==true&&raw[0]!='0')
		cout<<" ling";
	if(raw[0]!='0'&&size>1)
		cout<<" "<<trans[raw[0]-'0'];
	else if(size==1)
		cout<<trans[raw[0]-'0'];
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值